aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bftpd/bftpd_2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bftpd/bftpd_2.3.bb')
-rw-r--r--recipes/bftpd/bftpd_2.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/bftpd/bftpd_2.3.bb b/recipes/bftpd/bftpd_2.3.bb
new file mode 100644
index 0000000000..242a613be5
--- /dev/null
+++ b/recipes/bftpd/bftpd_2.3.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Portable ftp daemon"
+HOMEPAGE = "http://bftpd.sourceforge.net/"
+SECTION = "console/network"
+PR = "r2"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
+ file://bftpd.conf \
+ "
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${mandir}/man8
+ install -d ${D}${sysconfdir}
+
+ install -m 0755 ${S}/bftpd ${D}${sbindir}/bftpd
+ install -m 0755 ${S}/bftpd.8 ${D}${mandir}/man8/bftpd.8
+ install -m 0644 ${WORKDIR}/bftpd.conf ${D}${sysconfdir}/bftpd.conf
+}