aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bftpd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bftpd')
-rw-r--r--recipes/bftpd/bftpd_2.3.bb23
-rw-r--r--recipes/bftpd/files/bftpd.conf54
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes/bftpd/bftpd_2.3.bb b/recipes/bftpd/bftpd_2.3.bb
new file mode 100644
index 0000000000..242a613be5
--- /dev/null
+++ b/recipes/bftpd/bftpd_2.3.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Portable ftp daemon"
+HOMEPAGE = "http://bftpd.sourceforge.net/"
+SECTION = "console/network"
+PR = "r2"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
+ file://bftpd.conf \
+ "
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${mandir}/man8
+ install -d ${D}${sysconfdir}
+
+ install -m 0755 ${S}/bftpd ${D}${sbindir}/bftpd
+ install -m 0755 ${S}/bftpd.8 ${D}${mandir}/man8/bftpd.8
+ install -m 0644 ${WORKDIR}/bftpd.conf ${D}${sysconfdir}/bftpd.conf
+}
diff --git a/recipes/bftpd/files/bftpd.conf b/recipes/bftpd/files/bftpd.conf
new file mode 100644
index 0000000000..53b48a2c9a
--- /dev/null
+++ b/recipes/bftpd/files/bftpd.conf
@@ -0,0 +1,54 @@
+global {
+ DENY_LOGIN="no"
+ PORT="21"
+ PASSIVE_PORTS="0"
+ DATAPORT20="no"
+ PATH_BFTPDUTMP=""
+ XFER_BUFSIZE="2048"
+ CHANGE_BUFSIZE="no"
+ XFER_DELAY="0"
+ SHOW_HIDDEN_FILES="yes"
+ # This option determines whether files not readable
+ # to the ftp user will be shown in a directory listing.
+ SHOW_NONREADABLE_FILES="no"
+ ALLOW_FXP="no"
+ CONTROL_TIMEOUT="300"
+ DATA_TIMEOUT="30"
+ RATIO="none"
+ ROOTDIR="/"
+ UMASK="022"
+ LOGFILE="syslog"
+ HELLO_STRING="bftpd %v at %i ready."
+ AUTO_CHDIR="/"
+ AUTH="PASSWD"
+ RESOLVE_CLIENT_IP="no"
+ RESOLVE_UIDS="yes"
+ DO_CHROOT="yes""
+ LOG_WTMP="yes"
+ BIND_TO_ADDR="any"
+ AUTH_ETCSHELLS="no"
+ ALLOWCOMMAND_DELE="yes"
+ ALLOWCOMMAND_STOR="yes"
+ ALLOWCOMMAND_SITE="no"
+ QUIT_MSG="See you later..."
+ USERLIMIT_GLOBAL="0"
+ USERLIMIT_SINGLEUSER="0"
+ USERLIMIT_HOST="0"
+ GZ_UPLOAD="no"
+ GZ_DOWNLOAD="no"
+}
+
+user ftp {
+ #Any password fits.
+ ANONYMOUS_USER="yes"
+}
+
+user anonymous {
+ #If the client wants anonymous, ftp is taken instead.
+ ALIAS="ftp"
+}
+
+user root {
+}
+
+