aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bitlbee
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bitlbee')
-rw-r--r--recipes/bitlbee/bitlbee_1.0.4.bb59
-rw-r--r--recipes/bitlbee/files/configure.patch21
-rw-r--r--recipes/bitlbee/files/init-script31
3 files changed, 111 insertions, 0 deletions
diff --git a/recipes/bitlbee/bitlbee_1.0.4.bb b/recipes/bitlbee/bitlbee_1.0.4.bb
new file mode 100644
index 0000000000..41f7b1c97f
--- /dev/null
+++ b/recipes/bitlbee/bitlbee_1.0.4.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "Bitlbee is an IRC to IM gateway that support multiple IM protocols."
+HOMEPAGE = "http://www.bitlbee.org/"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+DEPENDS = "glib-2.0 gnutls"
+PR = "r0"
+
+SRC_URI = "http://get.bitlbee.org/src/${P}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://init-script"
+
+S = "${WORKDIR}/bitlbee-${PV}"
+
+EXTRA_OECONF = "--prefix=/usr \
+ --datadir=/usr/share/bitlbee \
+ --etcdir=/etc/bitlbee \
+ --oscar=0 \
+ --cpu=${TARGET_ARCH}"
+
+do_configure () {
+ # NOTE: bitlbee's configure script is not an autotool creation,
+ # so we do not use the default autotools_do_configure.
+ ./configure ${EXTRA_OECONF} || die "./configure failed"
+}
+
+do_compile () {
+ make CC="${CC}" LD="${LD}" || die "make failed"
+
+ # make bitlbeed forking server
+ cd ${S}/utils
+ ${CC} bitlbeed.c -o bitlbeed || die "bitlbeed failed to compile"
+}
+
+do_install () {
+ # install bitlbee
+ install -d ${D}${localstatedir}/lib/bitlbee
+ make install DESTDIR=${D} || die "install failed"
+ make install-etc DESTDIR=${D} || die "install failed"
+
+ # copy bitlbee forking server
+ install ${S}/utils/bitlbeed ${D}${sbindir}/bitlbeed
+
+ # copy init script
+ install -d ${D}${sysconfdir}/init.d
+ install ${WORKDIR}/init-script ${D}${sysconfdir}/init.d/bitlbee
+ sed -i -e "s:BITLBEED_EXEC:${sbindir}/bitlbeed:" ${D}${sysconfdir}/init.d/bitlbee
+ sed -i -e "s:BITLBEED_OPTS::" ${D}${sysconfdir}/init.d/bitlbee
+
+ # copy bitlbee utils
+ install -d ${D}${datadir}/bitlbee
+ cp ${S}/utils/* ${D}${datadir}/bitlbee/
+ rm ${D}${datadir}/bitlbee/bitlbeed*
+}
+
+pkg_postinst () {
+ chown nobody:nogroup ${localstatedir}/lib/bitlbee
+ chmod 700 ${localstatedir}/lib/bitlbee
+}
+
diff --git a/recipes/bitlbee/files/configure.patch b/recipes/bitlbee/files/configure.patch
new file mode 100644
index 0000000000..60488b1814
--- /dev/null
+++ b/recipes/bitlbee/files/configure.patch
@@ -0,0 +1,21 @@
+--- bitlbee/configure.orig 2006-11-25 13:01:16.000000000 +0100
++++ bitlbee/configure 2006-11-25 13:09:19.000000000 +0100
+@@ -57,6 +57,9 @@
+
+ --ssl=... SSL library to use (gnutls, nss, openssl, bogus, auto)
+ $ssl
++
++--arch=... The target architecture $arch
++--cpu=... The target cpu $cpu
+ EOF
+ exit;
+ fi
+@@ -366,6 +369,8 @@
+ ;;
+ esac
+
++echo Cpu: $cpu
++
+ echo
+ echo 'Configuration done:'
+
diff --git a/recipes/bitlbee/files/init-script b/recipes/bitlbee/files/init-script
new file mode 100644
index 0000000000..3ec3fdfb4a
--- /dev/null
+++ b/recipes/bitlbee/files/init-script
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ echo "Starting bitlbee daemon"
+ start-stop-daemon --start --startas BITLBEED_EXEC \
+ -c nobody:nogroup --exec BITLBEED_EXEC -- \
+ BITLBEED_OPTS /usr/sbin/bitlbee
+ [ $? -eq 0 ] || echo $? "Failed to start bitlbee daemon"
+ ;;
+
+ stop)
+ echo "Stopping bitlbee daemon"
+ start-stop-daemon --stop --signal 9 \
+ --exec BITLBEED_EXEC
+ [ $? -eq 0 ] || echo $? "Failed to stop bitlbee daemon"
+ ;;
+
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+
+ *)
+ echo "usage: $0 { start | stop }"
+ exit 1
+ ;;
+esac
+
+exit 0