aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bl')
-rw-r--r--recipes/bl/bl_cvs.bb40
-rw-r--r--recipes/bl/files/nokernelheader.patch43
-rw-r--r--recipes/bl/files/zaurus-hinge.bl-off10
-rw-r--r--recipes/bl/files/zaurus-hinge.bl-on10
4 files changed, 103 insertions, 0 deletions
diff --git a/recipes/bl/bl_cvs.bb b/recipes/bl/bl_cvs.bb
new file mode 100644
index 0000000000..2072ea10e5
--- /dev/null
+++ b/recipes/bl/bl_cvs.bb
@@ -0,0 +1,40 @@
+SECTION = "base"
+LICENSE= "GPL"
+PV = "0.0+cvs${SRCDATE}"
+DESCRIPTION = "Command line tool for iPaq backlight control"
+
+SRC_URI = "${HANDHELDS_CVS};module=apps/h3600_test \
+ file://nokernelheader.patch;patch=1;pnum=0 \
+ file://zaurus-hinge.bl-on \
+ file://zaurus-hinge.bl-off"
+
+
+S = "${WORKDIR}/h3600_test"
+PR = "r1"
+
+inherit pkgconfig
+
+FILES_${PN} = "${bindir}"
+
+do_configure (){
+}
+
+do_compile (){
+ oe_runmake bl CC="${CROSS_DIR}/bin/${TARGET_SYS}-gcc -I{STAGING_INCDIR} -L${STAGING_LIBDIR}" AS=${CROSS_DIR}/bin/${TARGET_SYS}-as LD=${CROSS_DIR}/bin/${TARGET_SYS}-ld
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}/etc/apm/resume.d
+ install -d ${D}/etc/zaurusd/hinge-close.d
+ install -d ${D}/etc/zaurusd/hinge-portrait.d
+ install -d ${D}/etc/zaurusd/hinge-landscape.d
+
+ install -m 4755 ${S}/bl ${D}${bindir}/bl
+
+ install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/apm/resume.d/00-backlight-on"
+ install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-landscape.d/00-backlight-on"
+ install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-portrait.d/00-backlight-on"
+ install -m 0755 "${WORKDIR}/zaurus-hinge.bl-off" "${D}/etc/zaurusd/hinge-close.d/00-backlight-off"
+
+}
diff --git a/recipes/bl/files/nokernelheader.patch b/recipes/bl/files/nokernelheader.patch
new file mode 100644
index 0000000000..d8b618583b
--- /dev/null
+++ b/recipes/bl/files/nokernelheader.patch
@@ -0,0 +1,43 @@
+--- bl.c.orig 2004-12-23 00:15:06.000000000 +0100
++++ bl.c 2004-12-23 00:22:59.000000000 +0100
+@@ -38,8 +38,39 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <linux/ioctl.h>
+-#include <linux/h3600_ts.h>
+
++enum flite_mode {
++ FLITE_MODE1 = 1,
++ FLITE_AUTO_MODE = 1, /* for reference only */
++ FLITE_MANUAL_MODE = 2, /* Use this normally? */
++ FLITE_GET_LIGHT_SENSOR = 3 /* Returns light reading in "brightness" field */
++};
++enum flite_pwr {
++ FLITE_PWR_OFF = 0,
++ FLITE_PWR_ON = 1
++};
++
++typedef struct h3600_ts_flite {
++ unsigned char mode;
++ unsigned char pwr;
++ unsigned char brightness;
++} FLITE_IN;
++
++/*************************** Updated "universal" structures *******************/
++
++/* Sets backlight for both H3100 and H3600 models - technically "frontlight" for H3600 */
++struct h3600_ts_backlight {
++enum flite_pwr power; /* 0 = off, 1 = on */
++unsigned char brightness; /* 0 - 255 */
++};
++
++/* Use 'f' as magic number */
++#define IOC_H3600_TS_MAGIC 'f'
++
++#define TS_GET_BACKLIGHT _IOR(IOC_H3600_TS_MAGIC, 20, struct h3600_ts_backlight)
++#define TS_SET_BACKLIGHT _IOW(IOC_H3600_TS_MAGIC, 20, struct h3600_ts_backlight)
++#define FLITE_ON _IOW(IOC_H3600_TS_MAGIC, 7, struct h3600_ts_flite)
++
+ /* The ioctl can be called from a ts, tsraw or key file descriptor */
+ #define DEV_NODE "/dev/touchscreen/0"
+ int debug = 0;
diff --git a/recipes/bl/files/zaurus-hinge.bl-off b/recipes/bl/files/zaurus-hinge.bl-off
new file mode 100644
index 0000000000..888f90bfc5
--- /dev/null
+++ b/recipes/bl/files/zaurus-hinge.bl-off
@@ -0,0 +1,10 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: zaurus-hinge.bl-off
+# Date: 04-Jun-06
+
+test -z "${ZD_BINDIR}" && ZD_BINDIR="/usr/bin"
+${ZD_BINDIR}/bl off
diff --git a/recipes/bl/files/zaurus-hinge.bl-on b/recipes/bl/files/zaurus-hinge.bl-on
new file mode 100644
index 0000000000..6d416ad8c4
--- /dev/null
+++ b/recipes/bl/files/zaurus-hinge.bl-on
@@ -0,0 +1,10 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: zaurus-hinge.bl-on
+# Date: 04-Jun-06
+
+test -z "${ZD_BINDIR}" && ZD_BINDIR="/usr/bin"
+${ZD_BINDIR}/bl on