aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/blackbox
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/blackbox')
-rw-r--r--recipes/blackbox/blackbox_0.70.1.bb21
-rw-r--r--recipes/blackbox/files/remove-host-includes.patch19
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/blackbox/blackbox_0.70.1.bb b/recipes/blackbox/blackbox_0.70.1.bb
new file mode 100644
index 0000000000..05010f97bb
--- /dev/null
+++ b/recipes/blackbox/blackbox_0.70.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Blackbox Window Manager"
+SECTION = "x11/wm"
+LICENSE = "GPL"
+DEPENDS = "libx11 libxext libxcomposite libxfixes libxdamage libxrender libxinerama libxpm xrandr xft"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/blackboxwm/blackbox-0.70.1.tar.gz \
+ file://remove-host-includes.patch;patch=1"
+S = "${WORKDIR}/blackbox-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus"
+
+#fix path of pc file
+do_install_append() {
+ sed -i s#${STAGING_LIBDIR}#${libdir}#g ${D}/${libdir}/pkgconfig/libbt.pc
+}
+do_stage_append () {
+ sed -i s#${STAGING_LIBDIR}#${libdir}#g ${STAGING_LIBDIR}/pkgconfig/libbt.pc
+}
diff --git a/recipes/blackbox/files/remove-host-includes.patch b/recipes/blackbox/files/remove-host-includes.patch
new file mode 100644
index 0000000000..bf557b51da
--- /dev/null
+++ b/recipes/blackbox/files/remove-host-includes.patch
@@ -0,0 +1,19 @@
+Index: blackbox-0.70.1/configure.ac
+===================================================================
+--- blackbox-0.70.1.orig/configure.ac
++++ blackbox-0.70.1/configure.ac
+@@ -8,14 +8,6 @@ AC_CONFIG_SRCDIR([src/blackbox.cc])
+ dnl Determine default prefix
+ test "x$prefix" = "xNONE" && prefix="$ac_default_prefix"
+
+-dnl Look in the most logical places for external libraries
+-CPPFLAGS="$CPPFLAGS -I$prefix/include"
+-LDFLAGS="$LDFLAGS -L$prefix/lib"
+-if test "x$prefix" != "x/usr/local"; then
+- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-fi
+-
+ dnl Locate required external software
+ AC_PROG_CC
+