aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bluez/bluez-dtl1-workaround_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bluez/bluez-dtl1-workaround_1.0.bb')
-rw-r--r--recipes/bluez/bluez-dtl1-workaround_1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/bluez/bluez-dtl1-workaround_1.0.bb b/recipes/bluez/bluez-dtl1-workaround_1.0.bb
new file mode 100644
index 0000000000..413d220508
--- /dev/null
+++ b/recipes/bluez/bluez-dtl1-workaround_1.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A nasty hack for for dtl1-cs driver to workaround suspend/resume."
+SECTION = "console"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "file://02dtl1_cs.sh"
+
+do_install() {
+ install -d ${D}${sysconfdir}/apm/event.d/
+ install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
+}
+
+#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
+FILES_${PN} += "${sysconfdir}/apm/"
+
+PACKAGE_ARCH = "all"