aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bluez/bluez-utils_3.36.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bluez/bluez-utils_3.36.bb')
-rw-r--r--recipes/bluez/bluez-utils_3.36.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/recipes/bluez/bluez-utils_3.36.bb b/recipes/bluez/bluez-utils_3.36.bb
new file mode 100644
index 0000000000..bd319e85f2
--- /dev/null
+++ b/recipes/bluez/bluez-utils_3.36.bb
@@ -0,0 +1,72 @@
+require bluez-utils3.inc
+
+PR = "r4"
+
+# removed hciattach-ti-bts.patch (landed upstream)
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
+ file://hcid.conf \
+ file://sbc-thumb.patch;patch=1"
+
+# see bluez-utils3.inc for the explanation of these option
+EXTRA_OECONF = " \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-hidd \
+ --enable-pand \
+ --enable-dund \
+ --disable-alsa \
+ --disable-cups \
+ --enable-glib \
+ --disable-sdpd \
+ --enable-network \
+ --enable-serial \
+ --enable-input \
+ --enable-audio \
+ --enable-echo \
+ --enable-configfile \
+ --enable-initscripts \
+ --enable-test \
+ --enable-hidd \
+ --enable-obex \
+ --enable-pand \
+ --enable-dund \
+ --enable-avctrl \
+ --enable-hid2hci \
+ --enable-dfutool \
+"
+
+CONFFILES_${PN} = " \
+ ${sysconfdir}/bluetooth/hcid.conf \
+ ${sysconfdir}/default/bluetooth \
+ "
+
+CONFFILES_${PN}-compat = " \
+ ${sysconfdir}/bluetooth/rfcomm.conf \
+ "
+
+PACKAGES =+ "bluez-audio"
+
+FILES_${PN} = " \
+ ${base_sbindir}/hcid \
+ ${libdir}/bluetooth/plugins/*.so \
+ ${sysconfdir}/init.d/bluetooth \
+ ${sysconfdir}/bluetooth/hcid.conf \
+ ${sysconfdir}/default \
+ ${sysconfdir}/dbus-1 \
+ ${base_sbindir}/hciattach \
+ "
+
+FILES_bluez-audio = " \
+ ${libdir}/bluetooth/plugins/libaudio.so \
+ ${libdir}/gstreamer-0.10/*.so \
+ "
+
+FILES_${PN}-dbg += " \
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/gstreamer-0.10/.debug \
+ "
+
+FILES_${PN}-dev += " \
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/gstreamer-0.10/*.la \
+ "