aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bmon
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bmon')
-rw-r--r--recipes/bmon/bmon_2.1.0.bb15
-rw-r--r--recipes/bmon/files/no-strip.patch13
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/bmon/bmon_2.1.0.bb b/recipes/bmon/bmon_2.1.0.bb
new file mode 100644
index 0000000000..d6cd03f614
--- /dev/null
+++ b/recipes/bmon/bmon_2.1.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Portable Bandwidth Monitor and rate estimator"
+HOMEPAGE = "http://people.suug.ch/~tgr/bmon/"
+SECTION = "console/utils"
+LICENSE = "MIT"
+# only works with libnl-0.5.0
+DEPENDS = "libnl"
+
+SRC_URI = "http://people.suug.ch/~tgr/bmon/files/bmon-2.1.0.tar.gz \
+ file://no-strip.patch;patch=1"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake
+}
diff --git a/recipes/bmon/files/no-strip.patch b/recipes/bmon/files/no-strip.patch
new file mode 100644
index 0000000000..f09e816857
--- /dev/null
+++ b/recipes/bmon/files/no-strip.patch
@@ -0,0 +1,13 @@
+Index: bmon-2.1.0/GNUmakefile
+===================================================================
+--- bmon-2.1.0.orig/GNUmakefile
++++ bmon-2.1.0/GNUmakefile
+@@ -50,7 +50,7 @@ distclean: clean
+ install:
+ ./install-sh -d -m 0755 $(DESTDIR)$(prefix)/bin
+ ./install-sh -d -m 0755 $(DESTDIR)$(mandir)/man1
+- ./install-sh -c -s -m 0755 src/bmon $(DESTDIR)$(prefix)/bin
++ ./install-sh -c -m 0755 src/bmon $(DESTDIR)$(prefix)/bin
+ ./install-sh -c -m 0644 man/bmon.1 $(DESTDIR)$(mandir)/man1
+
+ show: Makefile.opts