aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bochs/bochs_2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bochs/bochs_2.1.bb')
-rw-r--r--recipes/bochs/bochs_2.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/bochs/bochs_2.1.bb b/recipes/bochs/bochs_2.1.bb
new file mode 100644
index 0000000000..1ae3a23314
--- /dev/null
+++ b/recipes/bochs/bochs_2.1.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "An x86 Emulator based on SDL."
+HOMEPAGE = "http://bochs.sf.net"
+LICENSE = "GPL"
+PR = "r1"
+
+# needs a patch for recent g++
+BROKEN = "1"
+
+APPIMAGE = "doc/docbook/images/dlxlinux-in-linux.png"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bochs/bochs-${PV}.tar.gz \
+ file://compile.patch;patch=1"
+
+inherit autotools sdl
+
+EXTRA_OECONF = "--without-x \
+ --without-x11 \
+ --without-beos \
+ --without-win32 \
+ --without-macos \
+ --without-carbon \
+ --without-nogui \
+ --without-term \
+ --without-rfb \
+ --without-amigaos \
+ --with-sdl \
+ --without-svga \
+ --without-wx"
+
+do_compile() {
+ oe_runmake bochs bximage bxcommit
+}
+
+do_install() {
+ oe_runmake -i install # yes, ugly i know... but i can't get rid of that bailing out docbook crap atm.
+}