aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bochs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bochs')
-rw-r--r--recipes/bochs/bochs-2.1/compile.patch27
-rw-r--r--recipes/bochs/bochs_2.1.bb36
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes/bochs/bochs-2.1/compile.patch b/recipes/bochs/bochs-2.1/compile.patch
new file mode 100644
index 0000000000..063371d993
--- /dev/null
+++ b/recipes/bochs/bochs-2.1/compile.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- bochs-2.1/fpu/errors.c~compile 2003-11-01 19:36:19.000000000 +0100
++++ bochs-2.1/fpu/errors.c 2004-01-19 20:38:58.000000000 +0100
+@@ -18,7 +18,7 @@
+ | other processes using the emulator while swapping is in progress. |
+ +---------------------------------------------------------------------------*/
+
+-#include <linux/signal.h>
++#include <signal.h>
+ #include <stdio.h>
+
+ #include "fpu_emu.h"
+--- bochs-2.1/fpu/fpu_entry.c~compile 2003-11-01 19:36:19.000000000 +0100
++++ bochs-2.1/fpu/fpu_entry.c 2004-01-19 20:41:02.000000000 +0100
+@@ -31,7 +31,7 @@
+ #include "control_w.h"
+ #include "status_w.h"
+
+-#include <linux/signal.h>
++#include <signal.h>
+
+ #define __BAD__ FPU_illegal /* Illegal on an 80486, causes SIGILL */
+
diff --git a/recipes/bochs/bochs_2.1.bb b/recipes/bochs/bochs_2.1.bb
new file mode 100644
index 0000000000..1ae3a23314
--- /dev/null
+++ b/recipes/bochs/bochs_2.1.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "An x86 Emulator based on SDL."
+HOMEPAGE = "http://bochs.sf.net"
+LICENSE = "GPL"
+PR = "r1"
+
+# needs a patch for recent g++
+BROKEN = "1"
+
+APPIMAGE = "doc/docbook/images/dlxlinux-in-linux.png"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bochs/bochs-${PV}.tar.gz \
+ file://compile.patch;patch=1"
+
+inherit autotools sdl
+
+EXTRA_OECONF = "--without-x \
+ --without-x11 \
+ --without-beos \
+ --without-win32 \
+ --without-macos \
+ --without-carbon \
+ --without-nogui \
+ --without-term \
+ --without-rfb \
+ --without-amigaos \
+ --with-sdl \
+ --without-svga \
+ --without-wx"
+
+do_compile() {
+ oe_runmake bochs bximage bxcommit
+}
+
+do_install() {
+ oe_runmake -i install # yes, ugly i know... but i can't get rid of that bailing out docbook crap atm.
+}