aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bonjour
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bonjour')
-rw-r--r--recipes/bonjour/bonjour_107.6.bb33
-rw-r--r--recipes/bonjour/files/bonjour.conf14
-rwxr-xr-xrecipes/bonjour/files/bonjour.init48
3 files changed, 95 insertions, 0 deletions
diff --git a/recipes/bonjour/bonjour_107.6.bb b/recipes/bonjour/bonjour_107.6.bb
new file mode 100644
index 0000000000..3c176c017a
--- /dev/null
+++ b/recipes/bonjour/bonjour_107.6.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Bonjour is a networking technology that lets you create an instant network of computers and devices without any configuration."
+SECTION = "network"
+LICENSE = "Apache-2.0"
+
+RDEPENDS_bonjour = "update-rc.d"
+
+PR = "r3"
+
+SRC_URI = "http://www.opensource.apple.com/darwinsource/tarballs/other/mDNSResponder-${PV}.tar.gz \
+ file://bonjour.conf \
+ file://bonjour.init \
+ "
+
+S = "${WORKDIR}/mDNSResponder-${PV}"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "bonjour"
+INITSCRIPT_PARAMS = "defaults 50"
+
+EXTRA_OEMAKE = 'CC="${CC} ${LDFLAGS}" os=linux -C ${S}/mDNSPosix SAResponder'
+PARALLEL_MAKE = ""
+
+do_install() {
+
+ install -d ${D}${sbindir}
+ install -m 0755 mDNSPosix/build/prod/mDNSResponderPosix ${D}${sbindir}/mdnsd
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/bonjour.init ${D}${sysconfdir}/init.d/bonjour
+ install -m 0640 ${WORKDIR}/bonjour.conf ${D}${sysconfdir}/
+
+}
diff --git a/recipes/bonjour/files/bonjour.conf b/recipes/bonjour/files/bonjour.conf
new file mode 100644
index 0000000000..3a1eab7eff
--- /dev/null
+++ b/recipes/bonjour/files/bonjour.conf
@@ -0,0 +1,14 @@
+Web Server
+_http._tcp.
+80
+path=/
+
+TCP/IP Information
+_http._tcp.
+80
+path=/cgi-bin/ifconfig
+
+SSH
+_ssh._tcp.
+22
+none
diff --git a/recipes/bonjour/files/bonjour.init b/recipes/bonjour/files/bonjour.init
new file mode 100755
index 0000000000..1413ca6c12
--- /dev/null
+++ b/recipes/bonjour/files/bonjour.init
@@ -0,0 +1,48 @@
+#!/bin/sh
+#
+# A startup script for the Rendezvous mDNS Responder
+#
+
+set -e
+
+RDV_CONF=/etc/bonjour.conf
+prog=bonjour
+exe=/usr/sbin/mdnsd
+
+start() {
+ echo -n "Starting $prog: "
+ start-stop-daemon --start -x $exe -- -f $RDV_CONF -b
+ echo
+}
+
+stop() {
+ echo -n "Stopping $prog: "
+ start-stop-daemon --stop -x $exe
+ echo
+}
+
+reload()
+{
+ echo -n "Reloading $prog:"
+ killall -HUP `basename $exe`
+ echo
+}
+
+case "$1" in
+start)
+ start
+ ;;
+stop)
+ stop
+ ;;
+reload)
+ reload
+ ;;
+restart)
+ stop
+ start
+ ;;
+*)
+ echo "Usage: bonjour {start|stop|reload|restart}"
+ exit 1
+esac