aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bootchart/bootchart_0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bootchart/bootchart_0.9.bb')
-rw-r--r--recipes/bootchart/bootchart_0.9.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/bootchart/bootchart_0.9.bb b/recipes/bootchart/bootchart_0.9.bb
new file mode 100644
index 0000000000..98ff0c204d
--- /dev/null
+++ b/recipes/bootchart/bootchart_0.9.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Bootchart is a tool for performance analysis and visualization of the GNU/Linux boot process."
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.bootchart.org/"
+PR = "r1"
+
+#this only installs the loggers, you will need to run the renderers on your workstation
+#boot with 'init=/sbin/bootchartd' and do '/sbin/bootchartd stop' to end the logging
+
+#needed for a real /bin/sh and /bin/sleep
+DEPENDS = "bash coreutils acct"
+RDEPENDS = "bash coreutils acct"
+
+#this is a plain shell script
+PACKAGE_ARCH = "all"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bootchart/bootchart-${PV}.tar.bz2\
+ file://handheld.patch;patch=1"
+
+
+do_install() {
+ install -d ${D}/sbin
+ install -d ${D}/etc
+ install -d ${D}/bootchart
+ install -m 755 ${S}/script/bootchartd ${D}/sbin
+ install -m 644 ${S}/script/bootchartd.conf ${D}/etc
+}
+