aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bt950-cs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bt950-cs')
-rw-r--r--recipes/bt950-cs/bt950-cs/makefile.patch11
-rw-r--r--recipes/bt950-cs/bt950-cs_0.1.bb25
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/bt950-cs/bt950-cs/makefile.patch b/recipes/bt950-cs/bt950-cs/makefile.patch
new file mode 100644
index 0000000000..7aee180f99
--- /dev/null
+++ b/recipes/bt950-cs/bt950-cs/makefile.patch
@@ -0,0 +1,11 @@
+--- bt950-0.1/Makefile.orig 2002-11-17 04:39:14 +0100
++++ bt950-0.1/Makefile 2004-10-15 13:03:01 +0200
+@@ -1,7 +1,7 @@
+ INCLUDEDIR = /usr/src/linux/include
+
+ CC = gcc
+-CFLAGS = -D__KERNEL__ -I$(INCLUDEDIR) -I. -DMODULE -Wall -Wstrict-prototypes -O2
++CFLAGS = -D__KERNEL__ -I$(KERNEL_PATH)/include -I. -DMODULE -Wall -Wstrict-prototypes -O2
+
+
+ all: bt950_cs.o
diff --git a/recipes/bt950-cs/bt950-cs_0.1.bb b/recipes/bt950-cs/bt950-cs_0.1.bb
new file mode 100644
index 0000000000..66820a7e7d
--- /dev/null
+++ b/recipes/bt950-cs/bt950-cs_0.1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Linux driver for OX16C950 UART Bluetooth cards"
+SECTION = "kernel/modules"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.holtmann.org/linux/bluetooth/bt950.html"
+DEPENDS = "pcmcia-cs"
+RDEPENDS = "pcmcia-cs"
+PR = "r1"
+
+SRC_URI = "http://www.holtmann.org/linux/bluetooth/bt950-${PV}.tar.gz \
+file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/bt950-${PV}"
+
+PACKAGES = "${PN}-dbg kernel-module-bt950-cs"
+FILES_kernel-module-bt950-cs = "/etc/pcmcia/bt950.conf /lib/modules/${KERNEL_VERSION}/kernel/drivers/bluetooth/bt950_cs.o"
+
+inherit module
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/bluetooth/ \
+ ${D}${sysconfdir}/pcmcia/
+ install -m 0644 bt950_cs.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/bluetooth/
+ install -m 0644 bt950.conf ${D}${sysconfdir}/pcmcia/
+}
+