aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/btscanner/btscanner-1.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/btscanner/btscanner-1.0')
-rw-r--r--recipes/btscanner/btscanner-1.0/0909132213173.patch25
-rw-r--r--recipes/btscanner/btscanner-1.0/configure.patch45
2 files changed, 70 insertions, 0 deletions
diff --git a/recipes/btscanner/btscanner-1.0/0909132213173.patch b/recipes/btscanner/btscanner-1.0/0909132213173.patch
new file mode 100644
index 0000000000..1c4db165a5
--- /dev/null
+++ b/recipes/btscanner/btscanner-1.0/0909132213173.patch
@@ -0,0 +1,25 @@
+--- /tmp/bs_info.c 2005-10-07 16:04:20.842924176 +0200
++++ btscanner-1.0/bs_info.c 2005-10-07 16:08:26.368598600 +0200
+@@ -160,7 +160,7 @@
+ struct hci_conn_info_req *cr;
+ struct hci_request rq;
+ read_rssi_rp rp_rssi;
+- get_link_quality_rp rp_lq;
++ read_link_quality_rp rp_lq;
+ int err = 0;
+ int leave = 0;;
+
+@@ -292,11 +292,11 @@
+ memset(&rq, 0, sizeof(rq));
+ memset(&rp_lq, 0, sizeof(rp_lq));
+ rq.ogf = OGF_STATUS_PARAM;
+- rq.ocf = OCF_GET_LINK_QUALITY;
++ rq.ocf = OCF_READ_LINK_QUALITY;
+ rq.cparam = &handle;
+ rq.clen = 2;
+ rq.rparam = &rp_lq;
+- rq.rlen = GET_LINK_QUALITY_RP_SIZE;
++ rq.rlen = READ_LINK_QUALITY_RP_SIZE;
+
+ if (hci_send_req(dd, &rq, 100) < 0) {
+ p->lq_status = (uint8_t)-1;
diff --git a/recipes/btscanner/btscanner-1.0/configure.patch b/recipes/btscanner/btscanner-1.0/configure.patch
new file mode 100644
index 0000000000..a69d4df9e4
--- /dev/null
+++ b/recipes/btscanner/btscanner-1.0/configure.patch
@@ -0,0 +1,45 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- btscanner-1.0/configure.in~configure.patch 2003-10-14 13:01:20.000000000 +0200
++++ btscanner-1.0/configure.in 2004-07-16 11:55:24.000000000 +0200
+@@ -10,9 +10,8 @@
+ AC_PROG_CC
+
+ # Checks for libraries.
+-AC_HAVE_LIBRARY(curses,,[AC_MSG_ERROR([Curses not found])])
++AC_HAVE_LIBRARY(ncurses,,[AC_MSG_ERROR([Curses not found])])
+ AC_HAVE_LIBRARY(bluetooth,,[AC_MSG_ERROR([Bluetooth not found])])
+-AC_HAVE_LIBRARY(sdp,,[AC_MSG_ERROR([SDP not found])])
+ AC_HAVE_LIBRARY(pthread,,[AC_MSG_ERROR([Pthreads not found])])
+ AC_HAVE_LIBRARY(gdbm,,[AC_MSG_ERROR([GDBM not found])])
+
+--- btscanner-1.0/Makefile.in~configure.patch 2003-10-14 14:16:23.000000000 +0200
++++ btscanner-1.0/Makefile.in 2004-07-16 11:54:45.000000000 +0200
+@@ -6,9 +6,12 @@
+ CP = cp
+ MV = mv
+ RM = rm
++INSTALL = install
+ GZIP = gzip
+ MKDIR = mkdir
+
++DESTDIR =
++
+ all: $(EXECS)
+
+ btscanner.o: btscanner.c btscanner.h
+@@ -34,7 +37,7 @@
+ $(CC) $(CFLAGS) -c $*.c
+
+ install: all
+- $(MKDIR) -p @prefix@/bin
+- $(CP) $(EXECS) @prefix@/bin/
+- $(MKDIR) -p @prefix@/etc
+- $(CP) oui.txt @prefix@/etc/oui.txt
++ $(INSTALL) -d $(DESTDIR)/@prefix@/bin
++ $(INSTALL) -m 0755 $(EXECS) $(DESTDIR)/@prefix@/bin/
++ $(INSTALL) -d $(DESTDIR)/@prefix@/etc
++ $(INSTALL) -m 0444 oui.txt $(DESTDIR)/@prefix@/etc/oui.txt