summaryrefslogtreecommitdiffstats
path: root/recipes/btxml
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/btxml')
-rw-r--r--recipes/btxml/btxml.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/btxml/btxml.bb b/recipes/btxml/btxml.bb
new file mode 100644
index 0000000000..d072b85bac
--- /dev/null
+++ b/recipes/btxml/btxml.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Bluetooh Download Data from remote phones"
+HOMEPAGE = "http://www.saftware.de"
+SECTION = "apps"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "bluez-libs"
+
+SRC_URI = "http://www.saftware.de/bluetooth/btxml.c"
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} ${CPPFLAGS} -c -o btxml.o btxml.c
+ ${CC} -o btxml -lbluetooth -L${STAGING_LIBDIR} btxml.o
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 0775 btxml ${D}${bindir}/
+}