aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox/busybox_1.13.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/busybox/busybox_1.13.2.bb')
-rw-r--r--recipes/busybox/busybox_1.13.2.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.13.2.bb b/recipes/busybox/busybox_1.13.2.bb
new file mode 100644
index 0000000000..cc2cb2b39e
--- /dev/null
+++ b/recipes/busybox/busybox_1.13.2.bb
@@ -0,0 +1,49 @@
+require busybox.inc
+PR = "r16"
+
+SRC_URI = "\
+ http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
+ http://busybox.net/downloads/fixes-1.13.2/busybox-1.13.2-depmod.patch;patch=1 \
+ http://busybox.net/downloads/fixes-1.13.2/busybox-1.13.2-init.patch;patch=1 \
+ http://busybox.net/downloads/fixes-1.13.2/busybox-1.13.2-mdev.patch;patch=1 \
+ http://busybox.net/downloads/fixes-1.13.2/busybox-1.13.2-modprobe.patch;patch=1 \
+ http://busybox.net/downloads/fixes-1.13.2/busybox-1.13.2-tar.patch;patch=1 \
+ \
+ file://udhcpscript.patch;patch=1 \
+ file://udhcpc-fix-nfsroot.patch;patch=1 \
+ file://B921600.patch;patch=1 \
+ file://get_header_tar.patch;patch=1 \
+ file://busybox-appletlib-dependency.patch;patch=1 \
+ file://find-touchscreen.sh \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://mountall \
+ file://syslog \
+ file://syslog.conf \
+ file://umount.busybox \
+ file://defconfig \
+ file://mdev \
+ file://mdev.conf \
+"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ if [ "${TARGET_ARCH}" = "avr32" ] ; then
+ sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${S}/.config
+ fi
+ cml1_do_configure
+}
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/mdev
+ install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
+ install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
+}