aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox/busybox_1.13.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/busybox/busybox_1.13.2.bb')
-rw-r--r--recipes/busybox/busybox_1.13.2.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes/busybox/busybox_1.13.2.bb b/recipes/busybox/busybox_1.13.2.bb
index c1cc51baf1..03a7208229 100644
--- a/recipes/busybox/busybox_1.13.2.bb
+++ b/recipes/busybox/busybox_1.13.2.bb
@@ -39,12 +39,10 @@ SRC_URI = "\
EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
-do_configure () {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+do_configure_prepend () {
if [ "${TARGET_ARCH}" = "avr32" ] ; then
- sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${S}/.config
+ sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${WORKDIR}/defconfig
fi
- cml1_do_configure
}
do_install_append() {