summaryrefslogtreecommitdiffstats
path: root/recipes/busybox/busybox_1.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/busybox/busybox_1.9.2.bb')
-rw-r--r--recipes/busybox/busybox_1.9.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.9.2.bb b/recipes/busybox/busybox_1.9.2.bb
new file mode 100644
index 0000000000..e9aa820498
--- /dev/null
+++ b/recipes/busybox/busybox_1.9.2.bb
@@ -0,0 +1,27 @@
+require busybox.inc
+PR = "r6"
+
+SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
+ file://udhcpscript.patch;patch=1 \
+ file://adduser-longops.patch;patch=1 \
+ file://sort-z-nul.patch;patch=1;status=upstream \
+ file://topmem.patch;patch=1 \
+ file://busybox-appletlib-dependency.patch;patch=1 \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://mountall \
+ file://syslog \
+ file://syslog.conf \
+ file://umount.busybox \
+ file://defconfig"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ cml1_do_configure
+}