aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/busybox')
-rw-r--r--recipes/busybox/busybox-1.15.3/run-parts.in.usr-bin.patch12
-rw-r--r--recipes/busybox/busybox.inc57
-rw-r--r--recipes/busybox/busybox_1.11.3.bb10
-rw-r--r--recipes/busybox/busybox_1.13.2.bb34
-rw-r--r--recipes/busybox/busybox_1.14.3.bb10
-rw-r--r--recipes/busybox/busybox_1.15.3.bb15
-rw-r--r--recipes/busybox/busybox_1.2.1.bb6
-rw-r--r--recipes/busybox/busybox_1.2.2.bb2
-rw-r--r--recipes/busybox/busybox_1.7.2.bb12
-rw-r--r--recipes/busybox/busybox_1.9.2.bb10
10 files changed, 111 insertions, 57 deletions
diff --git a/recipes/busybox/busybox-1.15.3/run-parts.in.usr-bin.patch b/recipes/busybox/busybox-1.15.3/run-parts.in.usr-bin.patch
new file mode 100644
index 0000000000..6f209ce571
--- /dev/null
+++ b/recipes/busybox/busybox-1.15.3/run-parts.in.usr-bin.patch
@@ -0,0 +1,12 @@
+diff -uNr busybox-1.15.3.orig//include/applets.h busybox-1.15.3/include/applets.h
+--- busybox-1.15.3.orig//include/applets.h 2009-12-12 22:13:28.000000000 +0100
++++ busybox-1.15.3/include/applets.h 2010-04-30 15:35:40.000000000 +0200
+@@ -323,7 +323,7 @@
+ IF_RPM(APPLET(rpm, _BB_DIR_BIN, _BB_SUID_DROP))
+ IF_RPM2CPIO(APPLET(rpm2cpio, _BB_DIR_USR_BIN, _BB_SUID_DROP))
+ IF_RTCWAKE(APPLET(rtcwake, _BB_DIR_USR_BIN, _BB_SUID_DROP))
+-IF_RUN_PARTS(APPLET_ODDNAME(run-parts, run_parts, _BB_DIR_BIN, _BB_SUID_DROP, run_parts))
++IF_RUN_PARTS(APPLET_ODDNAME(run-parts, run_parts, _BB_DIR_USR_BIN, _BB_SUID_DROP, run_parts))
+ IF_RUNCON(APPLET(runcon, _BB_DIR_USR_BIN, _BB_SUID_DROP))
+ IF_RUNLEVEL(APPLET(runlevel, _BB_DIR_SBIN, _BB_SUID_DROP))
+ IF_RUNSV(APPLET(runsv, _BB_DIR_USR_BIN, _BB_SUID_DROP))
diff --git a/recipes/busybox/busybox.inc b/recipes/busybox/busybox.inc
index 1ee263ad90..8abda7c964 100644
--- a/recipes/busybox/busybox.inc
+++ b/recipes/busybox/busybox.inc
@@ -11,24 +11,24 @@ LICENSE = "GPLv2"
SECTION = "base"
PRIORITY = "required"
-INC_PR = "r26"
+INC_PR = "r29"
SRC_URI = "\
file://busybox-cron \
file://busybox-httpd \
file://busybox-udhcpd \
file://default.script file://simple.script \
- file://dhcp-hostname.patch;patch=1 \
+ file://dhcp-hostname.patch \
file://hwclock.sh \
- file://ifupdown-spurious-environ.patch;patch=1 \
+ file://ifupdown-spurious-environ.patch \
file://mount.busybox \
file://syslog \
file://syslog.conf \
- file://udhcpscript.patch;patch=1 \
+ file://udhcpscript.patch \
file://umount.busybox \
"
-SRC_URI_append_nylon = " file://xargs-double-size.patch;patch=1"
+SRC_URI_append_nylon = " file://xargs-double-size.patch"
export EXTRA_CFLAGS = "${CFLAGS}"
EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
@@ -46,12 +46,14 @@ RDEPENDS_${PN} += "${PN}-mountall"
RRECOMMENDS_${PN} += "libgcc ${PN}-syslog"
FILES_${PN}-httpd = "${sysconfdir}/init.d/busybox-httpd /srv/www"
-FILES_${PN}-syslog = "${sysconfdir}/init.d/syslog ${sysconfdir}/syslog.conf"
+FILES_${PN}-syslog = "${sysconfdir}/init.d/syslog.${PN} ${sysconfdir}/syslog.conf"
FILES_${PN}-udhcpd = "${sysconfdir}/init.d/busybox-udhcpd"
FILES_${PN} += "${datadir}/udhcpc"
-INITSCRIPT_PACKAGES = "${PN}-httpd ${PN}-syslog ${PN}-udhcpd"
+# syslog initscript is handled explicitly because order of
+# update-rc.d and update-alternatives is important (see below)
+INITSCRIPT_PACKAGES = "${PN}-httpd ${PN}-udhcpd"
INITSCRIPT_NAME_${PN}-httpd = "busybox-httpd"
INITSCRIPT_NAME_${PN}-syslog = "syslog"
INITSCRIPT_NAME_${PN}-udhcpd = "busybox-udhcpd"
@@ -78,6 +80,9 @@ do_configure () {
do_compile() {
unset CFLAGS CPPFLAGS CXXFLAGS
base_do_compile
+ # Busybox will force a strip, we do not want that. Future-proof
+ # in case later versions do this better.
+ cp busybox_unstripped busybox || true
}
do_install () {
@@ -104,7 +109,7 @@ do_install () {
ln -sf busybox ${D}${base_bindir}/sh
if grep -q "CONFIG_SYSLOGD=y" ${WORKDIR}/defconfig; then
- install -m 0755 ${WORKDIR}/syslog ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/syslog ${D}${sysconfdir}/init.d/syslog.${PN}
install -m 644 ${WORKDIR}/syslog.conf ${D}${sysconfdir}/
fi
if grep "CONFIG_CROND=y" ${WORKDIR}/defconfig; then
@@ -142,7 +147,9 @@ pkg_postinst_${PN} () {
if test "x$D" = "x"; then while read link; do if test ! -h "$link"; then case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; /*) to="/bin/busybox";; esac; busybox ln -s $to $link; fi; done </etc/busybox.links; fi
# This adds the links, remember that this has to work when building an image too, hence the $D
+ set +e
while read link; do case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; /*) to="/bin/busybox";; esac; bn=`basename $link`; update-alternatives --install $link $bn $to 50; done <$D/etc/busybox.links
+ set -e
}
pkg_postinst_${PN}-mountall () {
@@ -152,6 +159,40 @@ pkg_prerm_${PN}-mountall () {
update-alternatives --remove default_mountall mountall.${PN}
}
+pkg_postinst_${PN}-syslog () {
+ update-alternatives --install ${sysconfdir}/init.d/syslog syslog-init syslog.${PN} 50
+
+ if test "x$D" != "x"; then
+ OPT="-r $D"
+ else
+ OPT="-s"
+ fi
+ update-rc.d $OPT syslog defaults
+}
+
+pkg_prerm_${PN}-syslog () {
+ if test "x$D" = "x"; then
+ if test "$1" = "upgrade" -o "$1" = "remove"; then
+ /etc/init.d/syslog stop
+ fi
+ fi
+
+ update-alternatives --remove syslog-init syslog.${PN}
+}
+
+pkg_postrm_${PN}-syslog () {
+ if test "x$D" != "x"; then
+ OPT="-r $D"
+ else
+ OPT=""
+ fi
+ if test "$1" = "remove" -o "$1" = "purge"; then
+ if ! test -e "/etc/init.d/syslog"; then
+ update-rc.d $OPT syslog remove
+ fi
+ fi
+}
+
pkg_prerm_${PN} () {
# This is so you can make busybox commit suicide - removing busybox with no other packages
# providing its files, this will make update-alternatives work, but the update-rc.d part
diff --git a/recipes/busybox/busybox_1.11.3.bb b/recipes/busybox/busybox_1.11.3.bb
index 838e1bd54f..fa169efd9c 100644
--- a/recipes/busybox/busybox_1.11.3.bb
+++ b/recipes/busybox/busybox_1.11.3.bb
@@ -4,11 +4,11 @@ PR = "${INC_PR}.1"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
\
- file://udhcpscript.patch;patch=1 \
- file://B921600.patch;patch=1 \
- file://fdisk_lineedit_segfault.patch;patch=1 \
- file://iptunnel.patch;patch=1 \
- file://busybox-appletlib-dependency.patch;patch=1 \
+ file://udhcpscript.patch \
+ file://B921600.patch \
+ file://fdisk_lineedit_segfault.patch \
+ file://iptunnel.patch \
+ file://busybox-appletlib-dependency.patch \
file://busybox-cron \
file://busybox-httpd \
file://busybox-udhcpd \
diff --git a/recipes/busybox/busybox_1.13.2.bb b/recipes/busybox/busybox_1.13.2.bb
index d22819e7d4..57815f68af 100644
--- a/recipes/busybox/busybox_1.13.2.bb
+++ b/recipes/busybox/busybox_1.13.2.bb
@@ -3,24 +3,24 @@ PR = "${INC_PR}.1"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
- file://busybox-1.13.2-awk.patch;patch=1 \
- file://busybox-1.13.2-depmod.patch;patch=1 \
- file://busybox-1.13.2-init.patch;patch=1 \
- file://busybox-1.13.2-killall.patch;patch=1 \
- file://busybox-1.13.2-mdev.patch;patch=1 \
- file://busybox-1.13.2-modprobe.patch;patch=1 \
- file://busybox-1.13.2-printf.patch;patch=1 \
- file://busybox-1.13.2-syslogd.patch;patch=1 \
- file://busybox-1.13.2-tar.patch;patch=1 \
- file://busybox-1.13.2-top24.patch;patch=1 \
- file://busybox-1.13.2-unzip.patch;patch=1 \
- file://busybox-1.13.2-wget.patch;patch=1 \
+ file://busybox-1.13.2-awk.patch \
+ file://busybox-1.13.2-depmod.patch \
+ file://busybox-1.13.2-init.patch \
+ file://busybox-1.13.2-killall.patch \
+ file://busybox-1.13.2-mdev.patch \
+ file://busybox-1.13.2-modprobe.patch \
+ file://busybox-1.13.2-printf.patch \
+ file://busybox-1.13.2-syslogd.patch \
+ file://busybox-1.13.2-tar.patch \
+ file://busybox-1.13.2-top24.patch \
+ file://busybox-1.13.2-unzip.patch \
+ file://busybox-1.13.2-wget.patch \
\
- file://udhcpscript.patch;patch=1 \
- file://udhcpc-fix-nfsroot.patch;patch=1 \
- file://B921600.patch;patch=1 \
- file://get_header_tar.patch;patch=1 \
- file://busybox-appletlib-dependency.patch;patch=1 \
+ file://udhcpscript.patch \
+ file://udhcpc-fix-nfsroot.patch \
+ file://B921600.patch \
+ file://get_header_tar.patch \
+ file://busybox-appletlib-dependency.patch \
file://find-touchscreen.sh \
file://busybox-cron \
file://busybox-httpd \
diff --git a/recipes/busybox/busybox_1.14.3.bb b/recipes/busybox/busybox_1.14.3.bb
index d714310368..ebe018cc78 100644
--- a/recipes/busybox/busybox_1.14.3.bb
+++ b/recipes/busybox/busybox_1.14.3.bb
@@ -6,11 +6,11 @@ DEFAULT_PREFERENCE = "-1"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
\
- file://udhcpscript.patch;patch=1 \
- file://udhcpc-fix-nfsroot.patch;patch=1 \
- file://B921600.patch;patch=1 \
- file://get_header_tar.patch;patch=1 \
- file://busybox-appletlib-dependency.patch;patch=1 \
+ file://udhcpscript.patch \
+ file://udhcpc-fix-nfsroot.patch \
+ file://B921600.patch \
+ file://get_header_tar.patch \
+ file://busybox-appletlib-dependency.patch \
file://find-touchscreen.sh \
file://busybox-cron \
file://busybox-httpd \
diff --git a/recipes/busybox/busybox_1.15.3.bb b/recipes/busybox/busybox_1.15.3.bb
index 1e1aa1e32a..07103e855f 100644
--- a/recipes/busybox/busybox_1.15.3.bb
+++ b/recipes/busybox/busybox_1.15.3.bb
@@ -1,15 +1,16 @@
require busybox.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
\
- file://udhcpscript.patch;patch=1 \
- file://udhcpc-fix-nfsroot.patch;patch=1 \
- file://B921600.patch;patch=1 \
- file://get_header_tar.patch;patch=1 \
- file://busybox-appletlib-dependency.patch;patch=1 \
- file://0000-wget-no-check-certificate.patch;patch=1 \
+ file://udhcpscript.patch \
+ file://udhcpc-fix-nfsroot.patch \
+ file://B921600.patch \
+ file://get_header_tar.patch \
+ file://busybox-appletlib-dependency.patch \
+ file://0000-wget-no-check-certificate.patch \
+ file://run-parts.in.usr-bin.patch \
file://find-touchscreen.sh \
file://busybox-cron \
file://busybox-httpd \
diff --git a/recipes/busybox/busybox_1.2.1.bb b/recipes/busybox/busybox_1.2.1.bb
index 037584a198..c3ab626f2f 100644
--- a/recipes/busybox/busybox_1.2.1.bb
+++ b/recipes/busybox/busybox_1.2.1.bb
@@ -5,12 +5,12 @@ PR = "${INC_PR}.1"
SRC_URI += "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
\
- file://wget-long-options.patch;patch=1 \
- file://df_rootfs.patch;patch=1 \
+ file://wget-long-options.patch \
+ file://df_rootfs.patch \
file://defconfig"
SRC_URI[tarball.md5sum] = "362b3dc0f2023ddfda901dc1f1a74391"
SRC_URI[tarball.sha256sum] = "c6f955c7feafdb7c40645b3dc4c4a3c945477a2429633eef7b2a34ef01827410"
-SRC_URI_append_avr32 = " file://install-should-unlink-dest-if-it-exists.patch;patch=1"
+SRC_URI_append_avr32 = " file://install-should-unlink-dest-if-it-exists.patch"
do_configure () {
install -m 0644 ${WORKDIR}/defconfig ${S}/.config.oe
diff --git a/recipes/busybox/busybox_1.2.2.bb b/recipes/busybox/busybox_1.2.2.bb
index c160635998..2a373ae823 100644
--- a/recipes/busybox/busybox_1.2.2.bb
+++ b/recipes/busybox/busybox_1.2.2.bb
@@ -7,7 +7,7 @@ DEFAULT_PREFERENCE = "-1"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
\
- file://wget-long-options.patch;patch=1 \
+ file://wget-long-options.patch \
file://defconfig"
SRC_URI[tarball.md5sum] = "ae8a4c65b9464c8ece3483a3d3b9544c"
SRC_URI[tarball.sha256sum] = "4de9fb2bb018e381e64199b38d90cb25e71366c37a8995e9ab5ed206ebcb972f"
diff --git a/recipes/busybox/busybox_1.7.2.bb b/recipes/busybox/busybox_1.7.2.bb
index cd22797129..5887fbb7fd 100644
--- a/recipes/busybox/busybox_1.7.2.bb
+++ b/recipes/busybox/busybox_1.7.2.bb
@@ -11,17 +11,17 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://mountall \
file://syslog \
file://syslog.conf \
- file://udhcpscript.patch;patch=1 \
- file://busybox-appletlib-dependency.patch;patch=1 \
+ file://udhcpscript.patch \
+ file://busybox-appletlib-dependency.patch \
file://umount.busybox \
file://run_parts.c"
SRC_URI[tarball.md5sum] = "c91ec9756e2000073a9dd8fa9fc3f89e"
SRC_URI[tarball.sha256sum] = "83c4cc813124a43f13e2ebb83cea9da9909d63891b824bf4bc7006f0567db7cf"
-SRC_URI += "http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-ash.patch;patch=1;name=patch1 \
- http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-iptun.patch;patch=1;name=patch2 \
- http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-logger.patch;patch=1;name=patch3 \
- http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-tail.patch;patch=1;name=patch4 \
+SRC_URI += "http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-ash.patch;name=patch1 \
+ http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-iptun.patch;name=patch2 \
+ http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-logger.patch;name=patch3 \
+ http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-tail.patch;name=patch4 \
file://defconfig"
EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
diff --git a/recipes/busybox/busybox_1.9.2.bb b/recipes/busybox/busybox_1.9.2.bb
index 5e8e65a314..065cabf66b 100644
--- a/recipes/busybox/busybox_1.9.2.bb
+++ b/recipes/busybox/busybox_1.9.2.bb
@@ -2,11 +2,11 @@ require busybox.inc
PR = "${INC_PR}.1"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
- file://udhcpscript.patch;patch=1 \
- file://adduser-longops.patch;patch=1 \
- file://sort-z-nul.patch;patch=1;status=upstream \
- file://topmem.patch;patch=1 \
- file://busybox-appletlib-dependency.patch;patch=1 \
+ file://udhcpscript.patch \
+ file://adduser-longops.patch \
+ file://sort-z-nul.patch;status=upstream \
+ file://topmem.patch \
+ file://busybox-appletlib-dependency.patch \
file://busybox-cron \
file://busybox-httpd \
file://busybox-udhcpd \