aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/c3110x/cx3110x_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/c3110x/cx3110x_1.1.bb')
-rw-r--r--recipes/c3110x/cx3110x_1.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/c3110x/cx3110x_1.1.bb b/recipes/c3110x/cx3110x_1.1.bb
new file mode 100644
index 0000000000..15cf51427d
--- /dev/null
+++ b/recipes/c3110x/cx3110x_1.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "cx3110x wifi support as found in the Nokia 770/800"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r4"
+
+COMPATIBLE_MACHINE = "(nokia770|nokia800)"
+
+export KERNEL_SRC_DIR = ${STAGING_KERNEL_DIR}
+export LDFLAGS = ""
+
+SRC_URI = "https://garage.maemo.org/frs/download.php/939/cx3110x-1.1.tar.gz \
+ file://umac_binary.patch;patch=1 \
+ http://use.the.umac.ko.from.your.own.nokia800/umac.ko"
+
+S = "${WORKDIR}/cx3110x-${PV}"
+
+inherit module
+
+do_compile() {
+ cp ${WORKDIR}/umac.ko ${S}/src/binary_umac.o
+ ${OBJCOPY} ${S}/src/binary_umac.o -R __ksymtab
+ ${OBJCOPY} ${S}/src/binary_umac.o -R __ksymtab_strings
+ ${OBJCOPY} ${S}/src/binary_umac.o -R .gnu.linkonce.this_module
+ ${OBJCOPY} ${S}/src/binary_umac.o -R .modinfo
+ ${OBJCOPY} ${S}/src/binary_umac.o -R .init.text
+ ${OBJCOPY} ${S}/src/binary_umac.o -R .exit.text
+
+ oe_runmake modules
+}
+