aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cairo/libsvg-0.1.4
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cairo/libsvg-0.1.4')
-rw-r--r--recipes/cairo/libsvg-0.1.4/configure_fix.patch22
-rw-r--r--recipes/cairo/libsvg-0.1.4/gcc4_and_expat.patch19
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes/cairo/libsvg-0.1.4/configure_fix.patch b/recipes/cairo/libsvg-0.1.4/configure_fix.patch
new file mode 100644
index 0000000000..db20d5f05a
--- /dev/null
+++ b/recipes/cairo/libsvg-0.1.4/configure_fix.patch
@@ -0,0 +1,22 @@
+diff -urN libsvg-0.1.4.orig/configure.in libsvg-0.1.4/configure.in
+--- libsvg-0.1.4.orig/configure.in 2005-06-15 22:27:49.000000000 +0200
++++ libsvg-0.1.4/configure.in 2008-06-07 03:06:30.000000000 +0200
+@@ -9,15 +9,18 @@
+
+ # Increment if the interface has additions, changes, removals.
+ LT_CURRENT=1
++AC_SUBST(LT_CURRENT)
+
+ # Increment any time the source changes; set to
+ # 0 if you increment CURRENT
+ LT_REVISION=0
++AC_SUBST(LT_REVISION)
+
+ # Increment if any interfaces have been added; set to 0
+ # if any interfaces have been removed. removal has
+ # precedence over adding, so set to 0 if both happened.
+ LT_AGE=0
++AC_SUBST(LT_AGE)
+
+ VERSION_INFO="$LT_CURRENT:$LT_REVISION:$LT_AGE"
+ AC_SUBST(VERSION_INFO)
diff --git a/recipes/cairo/libsvg-0.1.4/gcc4_and_expat.patch b/recipes/cairo/libsvg-0.1.4/gcc4_and_expat.patch
new file mode 100644
index 0000000000..feec4ab74d
--- /dev/null
+++ b/recipes/cairo/libsvg-0.1.4/gcc4_and_expat.patch
@@ -0,0 +1,19 @@
+diff -bur libsvg-0.1.4~orig/src/svg_parser_expat.c libsvg-0.1.4/src/svg_parser_expat.c
+--- libsvg-0.1.4~orig/src/svg_parser_expat.c 2005-02-14 11:26:26.000000000 -0600
++++ libsvg-0.1.4/src/svg_parser_expat.c 2006-02-10 21:58:20.000000000 -0600
+@@ -30,6 +30,7 @@
+ #include "svgint.h"
+ #include "svg_hash.h"
+
++#ifndef LIBSVG_EXPAT
+ static void
+ _svg_parser_sax_start_element (void *closure,
+ const XML_Char *name,
+@@ -43,6 +44,7 @@
+ _svg_parser_sax_characters (void *closure,
+ const XML_Char *ch,
+ int len);
++#endif
+
+ static void
+ _svg_parser_sax_warning (void *closure,