aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/came/came-1.7
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/came/came-1.7')
-rw-r--r--recipes/came/came-1.7/compile.patch41
-rw-r--r--recipes/came/came-1.7/make.patch46
2 files changed, 87 insertions, 0 deletions
diff --git a/recipes/came/came-1.7/compile.patch b/recipes/came/came-1.7/compile.patch
new file mode 100644
index 0000000000..af2ff2e6ac
--- /dev/null
+++ b/recipes/came/came-1.7/compile.patch
@@ -0,0 +1,41 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- camE-1.7/webcam.c~compile
++++ camE-1.7/webcam.c
+@@ -39,6 +39,13 @@
+
+ #define VERSION "1.7"
+
++#ifndef TRUE
++# define TRUE 1
++#endif
++#ifndef FALSE
++# define FALSE 0
++#endif
++
+ void log(char *fmt,
+ ...);
+
+--- camE-1.7/Makefile~compile
++++ camE-1.7/Makefile
+@@ -5,6 +5,7 @@
+ exec_prefix=${prefix}
+ bindir=${exec_prefix}/bin
+ mandir=${prefix}/man
++docdir=${prefix}/doc/camE-1.7
+
+ CC=gcc
+ CFLAGS=-O2 -g -Wall
+@@ -34,6 +35,9 @@
+ install: all
+ $(INSTALL_DIR) $(DESTDIR)$(bindir)
+ $(INSTALL_PROGRAM) camE $(DESTDIR)$(bindir)
++ $(INSTALL_DIR) $(DESTDIR)$(docdir)
++ $(INSTALL_DATA) camE_text.style camE_title.style \
++ example.camErc.ssh example.camErc $(DESTDIR)$(docdir)
+
+ clean:
+ -rm -f $(OBJS) *.moc *~ core* *.bak TAGS camE
diff --git a/recipes/came/came-1.7/make.patch b/recipes/came/came-1.7/make.patch
new file mode 100644
index 0000000000..1dd9da1cfd
--- /dev/null
+++ b/recipes/came/came-1.7/make.patch
@@ -0,0 +1,46 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- camE-1.7/Makefile~make
++++ camE-1.7/Makefile
+@@ -1,13 +1,16 @@
+ srcdir=.
+
+-ROOT=
++DESTDIR=
+ prefix=/usr/local
+ exec_prefix=${prefix}
+-bindir=$(ROOT)${exec_prefix}/bin
+-mandir=$(ROOT)${prefix}/man
++bindir=${exec_prefix}/bin
++mandir=${prefix}/man
+
+ CC=gcc
+-CFLAGS=-O3 -g -Wall -I$(srcdir)/.. -I.. -D_GNU_SOURCE `giblib-config --cflags`
++CFLAGS=-O2 -g -Wall
++C_CFLAGS=-I$(srcdir) -D_GNU_SOURCE `giblib-config --cflags`
++LIBS=`giblib-config --libs` -lcurl
++LDFLAGS=
+
+ INSTALL=/usr/bin/install -c
+ INSTALL_PROGRAM=${INSTALL}
+@@ -23,11 +26,14 @@
+ all build: $(PROGS)
+
+ camE: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS) `giblib-config --libs` -lcurl
++ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
++
++%.o: %.c
++ $(CC) $(C_CFLAGS) $(CFLAGS) $< -c -o $@
+
+ install: all
+- $(INSTALL_DIR) $(bindir)
+- $(INSTALL_PROGRAM) camE $(bindir)
++ $(INSTALL_DIR) $(DESTDIR)$(bindir)
++ $(INSTALL_PROGRAM) camE $(DESTDIR)$(bindir)
+
+ clean:
+ -rm -f $(OBJS) *.moc *~ core* *.bak TAGS camE