aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cccc/cccc_3.pre84.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cccc/cccc_3.pre84.bb')
-rw-r--r--recipes/cccc/cccc_3.pre84.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/cccc/cccc_3.pre84.bb b/recipes/cccc/cccc_3.pre84.bb
new file mode 100644
index 0000000000..981de69006
--- /dev/null
+++ b/recipes/cccc/cccc_3.pre84.bb
@@ -0,0 +1,20 @@
+# BROKEN because it needs a native antlr, which in turn needs
+# a native java virtual machine. blech. -CL
+BROKEN = "1"
+DEPENDS += "antlr-native"
+
+DESCRIPTION = "C and C++ Code Counter, a software metrics tool"
+LICENSE = "PD"
+PRIORITY = "optional"
+SECTION = "devel"
+HOMEPAGE = "http://cccc.sourceforge.net/"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cccc/cccc-${PV}.tar.gz"
+
+EXTRA_OEMAKE = "'CCC=${CC}' 'LD=${CC}' \
+ 'CFLAGS=-c -I${S}/pccts/h -x c++ ${CFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}'"
+
+do_compile () {
+ oe_runmake -C cccc -f posixgcc.mak
+}