aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cherokee/cherokee_0.4.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cherokee/cherokee_0.4.29.bb')
-rw-r--r--recipes/cherokee/cherokee_0.4.29.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/cherokee/cherokee_0.4.29.bb b/recipes/cherokee/cherokee_0.4.29.bb
new file mode 100644
index 0000000000..42eae684e7
--- /dev/null
+++ b/recipes/cherokee/cherokee_0.4.29.bb
@@ -0,0 +1,26 @@
+# Cherokee web server
+DESCRIPTION = "Cherokee Web Server fast and secure"
+LICENSE = "GPL"
+SECTION = "network"
+DEPENDS = "openssl libpcre"
+SRC_URI = "http://www.0x50.org/download/0.4/${PV}/${P}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://Makefile.in.patch;patch=1 \
+ file://Makefile.cget.patch;patch=1 \
+ file://util.patch;patch=1"
+PR = "r1"
+
+inherit autotools
+
+LEAD_SONAME = "libcherokee-base"
+
+EXTRA_OECONF = "--enable-tls=openssl --disable-static --disable-nls"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_install_prepend () {
+ $BUILD_CC -DHAVE_SYS_STAT_H -o cherokee_replace cherokee_replace.c
+}