aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/chillispot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/chillispot')
-rw-r--r--recipes/chillispot/chillispot-0.98/no-ansi.patch10
-rw-r--r--recipes/chillispot/chillispot-1.0RC3/no-ansi.patch11
-rw-r--r--recipes/chillispot/chillispot_0.98.bb19
-rw-r--r--recipes/chillispot/chillispot_1.0RC3.bb17
-rw-r--r--recipes/chillispot/files/init35
5 files changed, 92 insertions, 0 deletions
diff --git a/recipes/chillispot/chillispot-0.98/no-ansi.patch b/recipes/chillispot/chillispot-0.98/no-ansi.patch
new file mode 100644
index 0000000000..3a58433d87
--- /dev/null
+++ b/recipes/chillispot/chillispot-0.98/no-ansi.patch
@@ -0,0 +1,10 @@
+--- chillispot-0.98/src/Makefile.am.org 2006-02-01 11:04:39.086469680 +0100
++++ chillispot-0.98/src/Makefile.am 2006-02-01 11:04:46.451350048 +0100
+@@ -1,6 +1,6 @@
+ sbin_PROGRAMS = chilli
+
+-AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -ansi -DSBINDIR='"$(sbindir)"'
++AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -DSBINDIR='"$(sbindir)"'
+
+ chilli_SOURCES = chilli.c defs.h tun.c tun.h cmdline.c cmdline.h ippool.c ippool.h radius.h radius.c md5.c md5.h redir.h redir.c dhcp.c dhcp.h syserr.c syserr.h iphash.c iphash.h
+
diff --git a/recipes/chillispot/chillispot-1.0RC3/no-ansi.patch b/recipes/chillispot/chillispot-1.0RC3/no-ansi.patch
new file mode 100644
index 0000000000..3a3ffab9a2
--- /dev/null
+++ b/recipes/chillispot/chillispot-1.0RC3/no-ansi.patch
@@ -0,0 +1,11 @@
+--- chillispot-1.0RC3/src/Makefile.am.org 2006-02-01 10:43:45.628024328 +0100
++++ chillispot-1.0RC3/src/Makefile.am 2006-02-01 10:43:50.922219488 +0100
+@@ -1,7 +1,7 @@
+ sbin_PROGRAMS = chilli
+
+ # add -pg to enable gprof
+-AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -ansi -DSBINDIR='"$(sbindir)"'
++AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -DSBINDIR='"$(sbindir)"'
+
+ chilli_SOURCES = chilli.c defs.h tun.c tun.h cmdline.c cmdline.h ippool.c ippool.h radius.h radius.c md5.c md5.h redir.h redir.c dhcp.c dhcp.h syserr.c syserr.h iphash.c iphash.h lookup.c lookup.h
+
diff --git a/recipes/chillispot/chillispot_0.98.bb b/recipes/chillispot/chillispot_0.98.bb
new file mode 100644
index 0000000000..98b123e394
--- /dev/null
+++ b/recipes/chillispot/chillispot_0.98.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
+HOMEPAGE = "http://www.chillispot.org/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
+ file://no-ansi.patch;patch=1 \
+ file://init"
+RRECOMMENDS = "kernel-module-tun"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${sysconfdir} ${D}${sysconfdir}/init.d
+ install ${S}/doc/chilli.conf ${D}${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/chillispot
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"
diff --git a/recipes/chillispot/chillispot_1.0RC3.bb b/recipes/chillispot/chillispot_1.0RC3.bb
new file mode 100644
index 0000000000..b4338a0ba0
--- /dev/null
+++ b/recipes/chillispot/chillispot_1.0RC3.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
+HOMEPAGE = "http://www.chillispot.org/"
+LICENSE = "GPL"
+SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
+ file://no-ansi.patch;patch=1 \
+ file://init"
+RDEPENDS = "kernel-module-tun"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/${sysconfdir} ${D}/${sysconfdir}/init.d
+ install ${S}/doc/chilli.conf ${D}/${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/chillispot
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"
diff --git a/recipes/chillispot/files/init b/recipes/chillispot/files/init
new file mode 100644
index 0000000000..784e519754
--- /dev/null
+++ b/recipes/chillispot/files/init
@@ -0,0 +1,35 @@
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/chilli
+NAME=chilli
+DESC=chillispot
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+ start-stop-daemon -S -p /var/run/$NAME.pid -x $DAEMON
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon -K -p /var/run/$NAME.pid -x $DAEMON
+ echo "$NAME."
+ ;;
+ restart|force-reload)
+ echo -n "Restarting $DESC: "
+ start-stop-daemon -K -p /var/run/$NAME.pid -x $DAEMON
+ sleep 1
+ start-stop-daemon -S -p /var/run/$NAME.pid -x $DAEMON
+ echo "$NAME."
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0