aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/chrony/chrony_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/chrony/chrony_git.bb')
-rw-r--r--recipes/chrony/chrony_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/chrony/chrony_git.bb b/recipes/chrony/chrony_git.bb
new file mode 100644
index 0000000000..bbba50c6f8
--- /dev/null
+++ b/recipes/chrony/chrony_git.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Chrony time synchronization"
+LICENSE = "GPL"
+CHRONY_REV="fe2cfe1faee10b3d972f79fe30b5c8ac09469409"
+DEPENDS += "readline"
+REDEPENDS += "readline"
+
+PV = "1.23+gitr${CHRONY_REV}"
+
+SRC_URI = "git://git.tuxfamily.org/gitroot/chrony/chrony.git;protocol=git;rev=${CHRONY_REV} \
+ file://chrony_start.sh \
+ file://chrony_stop.sh \
+ file://init \
+ file://chrony.conf \
+ file://chrony.keys \
+"
+S = "${WORKDIR}/git"
+
+do_configure() {
+ ${S}/configure
+}
+
+do_compile() {
+ unset CPPFLAGS
+ oe_runmake
+}
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0644 ${WORKDIR}/chrony.conf ${D}${sysconfdir}/
+ install -m 0644 ${WORKDIR}/chrony.keys ${D}${sysconfdir}/
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/chronyd
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/chrony_start.sh ${D}${bindir}
+ install -m 0755 ${WORKDIR}/chrony_stop.sh ${D}${bindir}
+} \ No newline at end of file