aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/classpath
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/classpath')
-rw-r--r--recipes/classpath/classpath-initial_0.93.bb4
-rw-r--r--recipes/classpath/classpath-minimal_0.96.1.bb4
-rw-r--r--recipes/classpath/classpath-minimal_0.97.2.bb14
-rw-r--r--recipes/classpath/classpath-native.inc3
-rw-r--r--recipes/classpath/classpath-native_0.97.2.bb20
-rw-r--r--recipes/classpath/classpath-native_0.98.bb12
-rw-r--r--recipes/classpath/classpath_0.95.bb6
-rw-r--r--recipes/classpath/classpath_0.96.1.bb6
-rw-r--r--recipes/classpath/classpath_0.97.2.bb20
-rw-r--r--recipes/classpath/classpath_0.98.bb10
-rw-r--r--recipes/classpath/inetlib_1.1.1.bb2
11 files changed, 49 insertions, 52 deletions
diff --git a/recipes/classpath/classpath-initial_0.93.bb b/recipes/classpath/classpath-initial_0.93.bb
index 2837775897..28e3277a64 100644
--- a/recipes/classpath/classpath-initial_0.93.bb
+++ b/recipes/classpath/classpath-initial_0.93.bb
@@ -10,8 +10,8 @@ PR = "r6"
DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
SRC_URI += "\
- file://autotools.patch;patch=1 \
- file://miscompilation-0.93.patch;patch=1 \
+ file://autotools.patch \
+ file://miscompilation-0.93.patch \
"
EXTRA_OECONF = "\
diff --git a/recipes/classpath/classpath-minimal_0.96.1.bb b/recipes/classpath/classpath-minimal_0.96.1.bb
index 4b886ff5c1..2bdca7ce0b 100644
--- a/recipes/classpath/classpath-minimal_0.96.1.bb
+++ b/recipes/classpath/classpath-minimal_0.96.1.bb
@@ -3,8 +3,8 @@ require classpath.inc
PR = "r7"
SRC_URI += "\
- file://gjar-prefix-patch.diff;patch=1;pnum=0 \
- file://xmlstream-fix.patch;patch=1;pnum=0 \
+ file://gjar-prefix-patch.diff;striplevel=0 \
+ file://xmlstream-fix.patch;striplevel=0 \
"
PROVIDES = "${PN} classpath"
diff --git a/recipes/classpath/classpath-minimal_0.97.2.bb b/recipes/classpath/classpath-minimal_0.97.2.bb
index 5920109abc..ce5eb20e64 100644
--- a/recipes/classpath/classpath-minimal_0.97.2.bb
+++ b/recipes/classpath/classpath-minimal_0.97.2.bb
@@ -3,13 +3,13 @@ require classpath.inc
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/${PBN}-${PV}"
SRC_URI += "\
- file://netif_16.patch;patch=1;pnum=0 \
- file://SimpleName.diff;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://decimalformat.patch;patch=1 \
- file://cp-byte-loophelper.patch;patch=1;pnum=0 \
+ file://netif_16.patch;striplevel=0 \
+ file://SimpleName.diff;striplevel=0 \
+ file://javanet-local.patch;striplevel=0 \
+ file://ecj_java_dir.patch \
+ file://autotools.patch \
+ file://decimalformat.patch \
+ file://cp-byte-loophelper.patch;striplevel=0 \
"
PR = "r3"
diff --git a/recipes/classpath/classpath-native.inc b/recipes/classpath/classpath-native.inc
index a2e19fdb14..6f737aee3c 100644
--- a/recipes/classpath/classpath-native.inc
+++ b/recipes/classpath/classpath-native.inc
@@ -37,6 +37,3 @@ EXTRA_OECONF = "\
--with-vm=java \
"
-do_stage() {
- oe_runmake install
-}
diff --git a/recipes/classpath/classpath-native_0.97.2.bb b/recipes/classpath/classpath-native_0.97.2.bb
index bea4b7683b..19c07a0578 100644
--- a/recipes/classpath/classpath-native_0.97.2.bb
+++ b/recipes/classpath/classpath-native_0.97.2.bb
@@ -6,16 +6,16 @@ PR = "r7"
# is usually not compiled. However if someone changes
# to --enable-local-sockets it will.
SRC_URI += "\
- file://netif_16.patch;patch=1;pnum=0 \
- file://SimpleName.diff;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
- file://sun-security-getproperty_0.96.1.patch;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://decimalformat.patch;patch=1 \
- file://cp-byte-loophelper.patch;patch=1;pnum=0 \
- file://miscompilation.patch;patch=1 \
- file://toolwrapper-exithook.patch;patch=1 \
+ file://netif_16.patch;striplevel=0 \
+ file://SimpleName.diff;striplevel=0 \
+ file://javanet-local.patch;striplevel=0 \
+ file://sun-security-getproperty_0.96.1.patch;striplevel=0 \
+ file://ecj_java_dir.patch \
+ file://autotools.patch \
+ file://decimalformat.patch \
+ file://cp-byte-loophelper.patch;striplevel=0 \
+ file://miscompilation.patch \
+ file://toolwrapper-exithook.patch \
"
do_unpackpost() {
diff --git a/recipes/classpath/classpath-native_0.98.bb b/recipes/classpath/classpath-native_0.98.bb
index 44a1530675..a8d8276bcf 100644
--- a/recipes/classpath/classpath-native_0.98.bb
+++ b/recipes/classpath/classpath-native_0.98.bb
@@ -9,12 +9,12 @@ PR = "r3"
# is usually not compiled. However if someone changes
# to --enable-local-sockets it will.
SRC_URI += "\
- file://SimpleName.diff;patch=1;pnum=0 \
- file://sun-security-getproperty.patch;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://miscompilation.patch;patch=1 \
- file://toolwrapper-exithook.patch;patch=1 \
+ file://SimpleName.diff;striplevel=0 \
+ file://sun-security-getproperty.patch;striplevel=0 \
+ file://ecj_java_dir.patch \
+ file://autotools.patch \
+ file://miscompilation.patch \
+ file://toolwrapper-exithook.patch \
"
do_unpackpost() {
diff --git a/recipes/classpath/classpath_0.95.bb b/recipes/classpath/classpath_0.95.bb
index 0dfad33444..384636960f 100644
--- a/recipes/classpath/classpath_0.95.bb
+++ b/recipes/classpath/classpath_0.95.bb
@@ -1,9 +1,9 @@
require classpath.inc
SRC_URI += "\
- file://gjar-prefix-patch.diff;patch=1;pnum=0 \
- file://xmlstream-fix.patch;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
+ file://gjar-prefix-patch.diff;striplevel=0 \
+ file://xmlstream-fix.patch;striplevel=0 \
+ file://javanet-local.patch;striplevel=0 \
"
PR = "r7"
diff --git a/recipes/classpath/classpath_0.96.1.bb b/recipes/classpath/classpath_0.96.1.bb
index 19e0059c7f..9751bbe8c1 100644
--- a/recipes/classpath/classpath_0.96.1.bb
+++ b/recipes/classpath/classpath_0.96.1.bb
@@ -1,9 +1,9 @@
require classpath.inc
SRC_URI += "\
- file://gjar-prefix-patch.diff;patch=1;pnum=0 \
- file://xmlstream-fix.patch;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
+ file://gjar-prefix-patch.diff;striplevel=0 \
+ file://xmlstream-fix.patch;striplevel=0 \
+ file://javanet-local.patch;striplevel=0 \
"
PR = "r9"
diff --git a/recipes/classpath/classpath_0.97.2.bb b/recipes/classpath/classpath_0.97.2.bb
index d8f070c2d3..b53ba2b456 100644
--- a/recipes/classpath/classpath_0.97.2.bb
+++ b/recipes/classpath/classpath_0.97.2.bb
@@ -1,16 +1,16 @@
require classpath.inc
SRC_URI += "\
- file://netif_16.patch;patch=1;pnum=0 \
- file://SimpleName.diff;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://decimalformat.patch;patch=1 \
- file://cp-byte-loophelper.patch;patch=1;pnum=0 \
- file://drawpolyline.patch;patch=1;pnum=0 \
- file://gtk-fix.patch;patch=1;pnum=0 \
- file://toolwrapper-exithook.patch;patch=1 \
+ file://netif_16.patch;striplevel=0 \
+ file://SimpleName.diff;striplevel=0 \
+ file://javanet-local.patch;striplevel=0 \
+ file://ecj_java_dir.patch \
+ file://autotools.patch \
+ file://decimalformat.patch \
+ file://cp-byte-loophelper.patch;striplevel=0 \
+ file://drawpolyline.patch;striplevel=0 \
+ file://gtk-fix.patch;striplevel=0 \
+ file://toolwrapper-exithook.patch \
"
PR = "r10"
diff --git a/recipes/classpath/classpath_0.98.bb b/recipes/classpath/classpath_0.98.bb
index 693ed8b7a3..d64fa078bf 100644
--- a/recipes/classpath/classpath_0.98.bb
+++ b/recipes/classpath/classpath_0.98.bb
@@ -1,11 +1,11 @@
require classpath.inc
SRC_URI += "\
- file://SimpleName.diff;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://fix-gmp.patch;patch=1 \
- file://toolwrapper-exithook.patch;patch=1 \
+ file://SimpleName.diff;striplevel=0 \
+ file://ecj_java_dir.patch \
+ file://autotools.patch \
+ file://fix-gmp.patch \
+ file://toolwrapper-exithook.patch \
"
PR = "r3"
diff --git a/recipes/classpath/inetlib_1.1.1.bb b/recipes/classpath/inetlib_1.1.1.bb
index e4b782406c..362d0aa1cf 100644
--- a/recipes/classpath/inetlib_1.1.1.bb
+++ b/recipes/classpath/inetlib_1.1.1.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://gnu.org/software/classpath/inetlib.html"
SRC_URI = "\
http://ftp.gnu.org/gnu/classpath/${BP}.tar.gz \
- file://datadir_java.patch;patch=1 \
+ file://datadir_java.patch \
"
inherit java-library autotools