aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/classpathx
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/classpathx')
-rw-r--r--recipes/classpathx/gnujaf-native_1.1.1.bb6
-rw-r--r--recipes/classpathx/gnujaf_1.1.1.bb5
-rw-r--r--recipes/classpathx/gnumail-native_1.1.2.bb5
-rw-r--r--recipes/classpathx/gnumail_1.1.2.bb6
4 files changed, 11 insertions, 11 deletions
diff --git a/recipes/classpathx/gnujaf-native_1.1.1.bb b/recipes/classpathx/gnujaf-native_1.1.1.bb
deleted file mode 100644
index b9abb4e974..0000000000
--- a/recipes/classpathx/gnujaf-native_1.1.1.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require gnujaf_${PV}.bb
-
-inherit java-native
-
-SRC_URI[md5sum] = "de50d7728e8140eb404f2b4554321f8c"
-SRC_URI[sha256sum] = "b1b5ef560d30fcb11fbf537246857d14110ce4eb2b200d4c54690472305d87b7"
diff --git a/recipes/classpathx/gnujaf_1.1.1.bb b/recipes/classpathx/gnujaf_1.1.1.bb
index 7ba6e67781..e0dfd24913 100644
--- a/recipes/classpathx/gnujaf_1.1.1.bb
+++ b/recipes/classpathx/gnujaf_1.1.1.bb
@@ -12,6 +12,8 @@ inherit autotools java-library
S = "${WORKDIR}/activation-${PV}"
+PR = "r1"
+
export JAVAC = "javac"
# Fake javadoc
@@ -30,3 +32,6 @@ do_compile() {
SRC_URI[md5sum] = "de50d7728e8140eb404f2b4554321f8c"
SRC_URI[sha256sum] = "b1b5ef560d30fcb11fbf537246857d14110ce4eb2b200d4c54690472305d87b7"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
diff --git a/recipes/classpathx/gnumail-native_1.1.2.bb b/recipes/classpathx/gnumail-native_1.1.2.bb
deleted file mode 100644
index 486645213c..0000000000
--- a/recipes/classpathx/gnumail-native_1.1.2.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require gnumail_${PV}.bb
-
-inherit native
-
-DEPENDS = "fastjar-native gnujaf-native inetlib-native"
diff --git a/recipes/classpathx/gnumail_1.1.2.bb b/recipes/classpathx/gnumail_1.1.2.bb
index cf85587015..3eab0f6d57 100644
--- a/recipes/classpathx/gnumail_1.1.2.bb
+++ b/recipes/classpathx/gnumail_1.1.2.bb
@@ -12,6 +12,9 @@ inherit java-library autotools
S = "${WORKDIR}/mail-${PV}"
DEPENDS = "fastjar-native gnujaf inetlib"
+DEPENDS_virtclass-native = "fastjar-native gnujaf-native inetlib-native"
+
+PR = "r1"
export JAVAC = "${STAGING_BINDIR_NATIVE}/javac"
export JAVA = "${STAGING_BINDIR_NATIVE}/java"
@@ -43,3 +46,6 @@ do_stage() {
SRC_URI[md5sum] = "0a94ff4328ceb6a4131be96946976a33"
SRC_URI[sha256sum] = "5eb09597a8f81bfc943206e3e0f45b963ba605a646051c353374f1b475bb9f04"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"