aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clucene/clucene-core_0.9.21b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/clucene/clucene-core_0.9.21b.bb')
-rw-r--r--recipes/clucene/clucene-core_0.9.21b.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/clucene/clucene-core_0.9.21b.bb b/recipes/clucene/clucene-core_0.9.21b.bb
new file mode 100644
index 0000000000..d533f2b235
--- /dev/null
+++ b/recipes/clucene/clucene-core_0.9.21b.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "CLucene is a C++ port of Lucene: the high-performance, \
+full-featured text search engine written in Java."
+HOMEPAGE = "http://clucene.sf.net"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "libtool"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/clucene/clucene-core-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-multithreading dps_static_const_type=2"
+
+do_configure() {
+ gnu-configize
+ cp ${STAGING_DATADIR}/libtool/config.sub ${S}/config
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dev += "${libdir}/CLucene"