summaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter/enable_tests-0.4.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/clutter/clutter/enable_tests-0.4.patch')
-rw-r--r--recipes/clutter/clutter/enable_tests-0.4.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes/clutter/clutter/enable_tests-0.4.patch b/recipes/clutter/clutter/enable_tests-0.4.patch
new file mode 100644
index 0000000000..3178a2cd6c
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests-0.4.patch
@@ -0,0 +1,52 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter-0-4/tests/Makefile.am
+===================================================================
+--- clutter-0-4.orig/tests/Makefile.am 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/Makefile.am 2007-11-06 21:49:48.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-boxes test-perspective test-rotate test-depth \
+ test-threads test-timeline
+@@ -24,4 +24,9 @@ test_depth_SOURCES = test-depth.c
+ test_threads_SOURCES = test-threads.c
+ test_timeline_SOURCES = test-timeline.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png
+Index: clutter-0-4/tests/test-actors.c
+===================================================================
+--- clutter-0-4.orig/tests/test-actors.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-actors.c 2007-11-06 21:49:28.000000000 +0000
+@@ -143,7 +143,7 @@ main (int argc, char *argv[])
+ stage = clutter_stage_get_default ();
+ clutter_actor_set_size (stage, 800, 600);
+
+- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+
+ if (!pixbuf)
+ g_error("pixbuf load failed");
+Index: clutter-0-4/tests/test-text.c
+===================================================================
+--- clutter-0-4.orig/tests/test-text.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-text.c 2007-11-06 21:49:28.000000000 +0000
+@@ -27,7 +27,7 @@ main (int argc, char *argv[])
+
+ stage = clutter_stage_get_default ();
+
+- if (!g_file_get_contents ("test-text.c", &text, &size, NULL))
++ if (!g_file_get_contents ("/usr/share/clutter/test-text.c", &text, &size, NULL))
+ g_error("g_file_get_contents() of test-text.c failed");
+
+ clutter_actor_set_size (stage, 800, 600);