aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/clutter/clutter')
-rw-r--r--recipes/clutter/clutter/enable-tests-r2990.patch50
-rw-r--r--recipes/clutter/clutter/enable_tests-0.4.patch52
-rw-r--r--recipes/clutter/clutter/enable_tests-0.6.patch40
-rw-r--r--recipes/clutter/clutter/enable_tests.patch48
4 files changed, 190 insertions, 0 deletions
diff --git a/recipes/clutter/clutter/enable-tests-r2990.patch b/recipes/clutter/clutter/enable-tests-r2990.patch
new file mode 100644
index 0000000000..4f449b1177
--- /dev/null
+++ b/recipes/clutter/clutter/enable-tests-r2990.patch
@@ -0,0 +1,50 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2008-06-26 16:46:26.000000000 +0100
++++ clutter/tests/Makefile.am 2008-06-26 16:46:50.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-perspective test-rotate test-depth \
+ test-threads test-timeline test-timeline-dup-frames \
+@@ -17,8 +17,8 @@
+ test-invariants
+
+ if X11_TESTS
+-noinst_PROGRAMS += test-pixmap
+-noinst_PROGRAMS += test-devices
++bin_PROGRAMS += test-pixmap
++bin_PROGRAMS += test-devices
+ endif
+
+ INCLUDES = -I$(top_srcdir)/ -I$(top_srcdir)/clutter -I$(top_builddir)/clutter
+@@ -73,4 +73,9 @@
+ test_invariants_SOURCES = test-invariants.c
+ test_devices_SOURCES = test-devices.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2008-06-26 16:46:26.000000000 +0100
++++ clutter/tests/test-actors.c 2008-06-26 16:46:31.000000000 +0100
+@@ -195,7 +195,7 @@
+ /* Create a texture from file, then clone in to same resources */
+ if (i == 0)
+ {
+- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
++ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
+ &error)) == NULL)
+ {
+ g_error ("image load failed: %s", error->message);
diff --git a/recipes/clutter/clutter/enable_tests-0.4.patch b/recipes/clutter/clutter/enable_tests-0.4.patch
new file mode 100644
index 0000000000..3178a2cd6c
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests-0.4.patch
@@ -0,0 +1,52 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter-0-4/tests/Makefile.am
+===================================================================
+--- clutter-0-4.orig/tests/Makefile.am 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/Makefile.am 2007-11-06 21:49:48.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-boxes test-perspective test-rotate test-depth \
+ test-threads test-timeline
+@@ -24,4 +24,9 @@ test_depth_SOURCES = test-depth.c
+ test_threads_SOURCES = test-threads.c
+ test_timeline_SOURCES = test-timeline.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png
+Index: clutter-0-4/tests/test-actors.c
+===================================================================
+--- clutter-0-4.orig/tests/test-actors.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-actors.c 2007-11-06 21:49:28.000000000 +0000
+@@ -143,7 +143,7 @@ main (int argc, char *argv[])
+ stage = clutter_stage_get_default ();
+ clutter_actor_set_size (stage, 800, 600);
+
+- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+
+ if (!pixbuf)
+ g_error("pixbuf load failed");
+Index: clutter-0-4/tests/test-text.c
+===================================================================
+--- clutter-0-4.orig/tests/test-text.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-text.c 2007-11-06 21:49:28.000000000 +0000
+@@ -27,7 +27,7 @@ main (int argc, char *argv[])
+
+ stage = clutter_stage_get_default ();
+
+- if (!g_file_get_contents ("test-text.c", &text, &size, NULL))
++ if (!g_file_get_contents ("/usr/share/clutter/test-text.c", &text, &size, NULL))
+ g_error("g_file_get_contents() of test-text.c failed");
+
+ clutter_actor_set_size (stage, 800, 600);
diff --git a/recipes/clutter/clutter/enable_tests-0.6.patch b/recipes/clutter/clutter/enable_tests-0.6.patch
new file mode 100644
index 0000000000..544a7e588c
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests-0.6.patch
@@ -0,0 +1,40 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter-0-6/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2007-11-06 12:29:17.000000000 +0000
++++ clutter-0-6/tests/Makefile.am 2007-11-06 12:30:11.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-boxes test-perspective test-rotate test-depth \
+ test-threads test-timeline test-score test-script
+@@ -26,4 +26,9 @@ test_timeline_SOURCES = test-timeline.c
+ test_score_SOURCES = test-score.c
+ test_script_SOURCES = test-script.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter-0-6/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2007-11-06 12:29:17.000000000 +0000
++++ clutter-0-6/tests/test-actors.c 2007-11-06 12:29:21.000000000 +0000
+@@ -143,7 +143,7 @@ main (int argc, char *argv[])
+ stage = clutter_stage_get_default ();
+ clutter_actor_set_size (stage, 800, 600);
+
+- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+
+ if (!pixbuf)
+ g_error("pixbuf load failed");
+
diff --git a/recipes/clutter/clutter/enable_tests.patch b/recipes/clutter/clutter/enable_tests.patch
new file mode 100644
index 0000000000..4a99968fa3
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests.patch
@@ -0,0 +1,48 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2008-04-25 16:45:17.000000000 +0100
++++ clutter/tests/Makefile.am 2008-04-25 16:47:12.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-perspective test-rotate test-depth \
+ test-threads test-timeline test-timeline-dup-frames \
+@@ -14,7 +14,7 @@
+ test-cogl-tex-polygon test-stage-read-pixels
+
+ if X11_TESTS
+-noinst_PROGRAMS += test-pixmap
++bin_PROGRAMS += test-pixmap
+ endif
+
+ INCLUDES = -I$(top_srcdir)/ -I$(top_builddir)/clutter
+@@ -61,4 +61,9 @@
+ test_cogl_offscreen_SOURCES = test-cogl-offscreen.c
+ test_stage_read_pixels_SOURCES = test-stage-read-pixels.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
++++ clutter/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
+@@ -184,7 +184,7 @@
+ /* Create a texture from file, then clone in to same resources */
+ if (i == 0)
+ {
+- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
++ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
+ &error)) == NULL)
+ {
+ g_error ("image load failed: %s", error->message);