aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clutter
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/clutter')
-rw-r--r--recipes/clutter/aaina.inc12
-rw-r--r--recipes/clutter/aaina_svn.bb8
-rw-r--r--recipes/clutter/clutter-box2d.inc19
-rw-r--r--recipes/clutter/clutter-box2d_svn.bb10
-rw-r--r--recipes/clutter/clutter-cairo.inc15
-rw-r--r--recipes/clutter/clutter-cairo/enable_examples.patch28
-rw-r--r--recipes/clutter/clutter-cairo_svn.bb10
-rw-r--r--recipes/clutter/clutter-fpu.inc6
-rw-r--r--recipes/clutter/clutter-glx_svn.bb9
-rw-r--r--recipes/clutter/clutter-gst.inc19
-rw-r--r--recipes/clutter/clutter-gst/autofoo-0.4.patch15
-rw-r--r--recipes/clutter/clutter-gst/autofoo.patch25
-rw-r--r--recipes/clutter/clutter-gst_0.4svn.bb9
-rw-r--r--recipes/clutter/clutter-gst_svn.bb8
-rw-r--r--recipes/clutter/clutter-gtk-0.6_git.bb9
-rw-r--r--recipes/clutter/clutter-gtk-0.8_git.bb9
-rw-r--r--recipes/clutter/clutter-gtk.inc13
-rw-r--r--recipes/clutter/clutter-gtk_git.bb10
-rw-r--r--recipes/clutter/clutter.inc64
-rw-r--r--recipes/clutter/clutter/enable-tests-r2990.patch50
-rw-r--r--recipes/clutter/clutter/enable_tests-0.4.patch52
-rw-r--r--recipes/clutter/clutter/enable_tests-0.6.patch40
-rw-r--r--recipes/clutter/clutter/enable_tests.patch48
-rw-r--r--recipes/clutter/clutter_0.4svn.bb13
-rw-r--r--recipes/clutter/clutter_0.6svn.bb8
-rw-r--r--recipes/clutter/clutter_0.8+git.bb13
-rw-r--r--recipes/clutter/clutter_svn.bb14
-rw-r--r--recipes/clutter/moblin-proto/fix.patch22
-rw-r--r--recipes/clutter/moblin-proto/paths.patch15
-rw-r--r--recipes/clutter/moblin-proto_git.bb19
-rw-r--r--recipes/clutter/table.inc17
-rw-r--r--recipes/clutter/table/fixes.patch14
-rw-r--r--recipes/clutter/table_svn.bb10
-rw-r--r--recipes/clutter/tidy.inc24
-rw-r--r--recipes/clutter/tidy/autofoo.patch11
-rw-r--r--recipes/clutter/tidy/tidy-enable-tests.patch20
-rw-r--r--recipes/clutter/tidy_svn.bb10
37 files changed, 698 insertions, 0 deletions
diff --git a/recipes/clutter/aaina.inc b/recipes/clutter/aaina.inc
new file mode 100644
index 0000000000..fbef34f563
--- /dev/null
+++ b/recipes/clutter/aaina.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "Aaina Clutter Demo"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "GPL"
+
+DEPENDS = "clutter libxml2 gtk+ neon"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/recipes/clutter/aaina_svn.bb b/recipes/clutter/aaina_svn.bb
new file mode 100644
index 0000000000..862dfd8933
--- /dev/null
+++ b/recipes/clutter/aaina_svn.bb
@@ -0,0 +1,8 @@
+require aaina.inc
+
+SRCREV = "3597"
+PV = "0.3.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk/toys;module=aaina;proto=http"
+
+S = "${WORKDIR}/aaina"
diff --git a/recipes/clutter/clutter-box2d.inc b/recipes/clutter/clutter-box2d.inc
new file mode 100644
index 0000000000..8189d12bbb
--- /dev/null
+++ b/recipes/clutter/clutter-box2d.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Clutter Box2D"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "GPLv2"
+
+DEPENDS = "clutter"
+
+# The main clutter lib is machine specific so we need to be too
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit autotools pkgconfig gtk-doc
+
+do_stage () {
+ autotools_stage_all
+}
+
+do_install_append () {
+ install -d ${D}${bindir}
+ install ${S}/examples/.libs/blockbox ${D}${bindir}
+}
diff --git a/recipes/clutter/clutter-box2d_svn.bb b/recipes/clutter/clutter-box2d_svn.bb
new file mode 100644
index 0000000000..24b9b1feae
--- /dev/null
+++ b/recipes/clutter/clutter-box2d_svn.bb
@@ -0,0 +1,10 @@
+require clutter-box2d.inc
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r4"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=${PN};proto=http"
+
+S = "${WORKDIR}/${PN}"
+
+
diff --git a/recipes/clutter/clutter-cairo.inc b/recipes/clutter/clutter-cairo.inc
new file mode 100644
index 0000000000..1095a7e8ef
--- /dev/null
+++ b/recipes/clutter/clutter-cairo.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "Clutter Cairo"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+DEPENDS = "clutter cairo"
+
+PACKAGES =+ "${PN}-examples"
+FILES_${PN}-examples = "${bindir}/flowers ${bindir}/clock"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/recipes/clutter/clutter-cairo/enable_examples.patch b/recipes/clutter/clutter-cairo/enable_examples.patch
new file mode 100644
index 0000000000..c5ed63ff12
--- /dev/null
+++ b/recipes/clutter/clutter-cairo/enable_examples.patch
@@ -0,0 +1,28 @@
+---
+ examples/Makefile.am | 2 +-
+ examples/flowers.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: clutter-cairo/examples/Makefile.am
+===================================================================
+--- clutter-cairo.orig/examples/Makefile.am 2008-08-11 16:30:04.000000000 +0100
++++ clutter-cairo/examples/Makefile.am 2008-08-11 16:30:24.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = clock flowers bubbles
++bin_PROGRAMS = clock flowers bubbles
+
+ INCLUDES = -I$(top_srcdir)/ @GCC_FLAGS@ @DEPS_CFLAGS@
+ AM_LDFLAGS = @DEPS_LIBS@ $(top_builddir)/libclutter-cairo-@CLUTTER_CAIRO_MAJORMINOR@.la
+Index: clutter-cairo/examples/flowers.c
+===================================================================
+--- clutter-cairo.orig/examples/flowers.c 2008-08-11 16:30:04.000000000 +0100
++++ clutter-cairo/examples/flowers.c 2008-08-11 16:30:10.000000000 +0100
+@@ -11,7 +11,7 @@
+
+ #define PETAL_MIN 20
+ #define PETAL_VAR 40
+-#define N_FLOWERS 40 /* reduce if you have a small card */
++#define N_FLOWERS 8 /* reduce if you have a small card */
+
+ typedef struct Flower
+ {
diff --git a/recipes/clutter/clutter-cairo_svn.bb b/recipes/clutter/clutter-cairo_svn.bb
new file mode 100644
index 0000000000..1084c1cc16
--- /dev/null
+++ b/recipes/clutter/clutter-cairo_svn.bb
@@ -0,0 +1,10 @@
+require clutter-cairo.inc
+
+PV = "0.8.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=${PN};proto=http \
+ file://enable_examples.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+
diff --git a/recipes/clutter/clutter-fpu.inc b/recipes/clutter/clutter-fpu.inc
new file mode 100644
index 0000000000..21a16feac2
--- /dev/null
+++ b/recipes/clutter/clutter-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_clutter_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--without-fpu"
+ return ""
+
diff --git a/recipes/clutter/clutter-glx_svn.bb b/recipes/clutter/clutter-glx_svn.bb
new file mode 100644
index 0000000000..8a2a1fa1ed
--- /dev/null
+++ b/recipes/clutter/clutter-glx_svn.bb
@@ -0,0 +1,9 @@
+require clutter.inc
+
+PV = "0.3.1+svn${SRCDATE}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=clutter;proto=http"
+
+S = "${WORKDIR}/clutter"
+
+
diff --git a/recipes/clutter/clutter-gst.inc b/recipes/clutter/clutter-gst.inc
new file mode 100644
index 0000000000..caaa7559b8
--- /dev/null
+++ b/recipes/clutter/clutter-gst.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Clutter GStreamer"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+DEPENDS = "clutter gstreamer gst-plugins-base"
+
+PACKAGES =+ "${PN}-examples"
+FILES_${PN}-examples = "${bindir}/video-player ${bindir}/video-sink ${bindir}/audio"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ touch ${S}/gtk-doc.make
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/recipes/clutter/clutter-gst/autofoo-0.4.patch b/recipes/clutter/clutter-gst/autofoo-0.4.patch
new file mode 100644
index 0000000000..54df63d297
--- /dev/null
+++ b/recipes/clutter/clutter-gst/autofoo-0.4.patch
@@ -0,0 +1,15 @@
+---
+ doc/reference/Makefile.am | 2 +-
+ examples/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: clutter-gst/examples/Makefile.am
+===================================================================
+--- clutter-gst.orig/examples/Makefile.am 2007-11-06 12:31:36.000000000 +0000
++++ clutter-gst/examples/Makefile.am 2007-11-06 18:53:59.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = video-player video-sink audio
++bin_PROGRAMS = video-player video-sink audio
+
+ INCLUDES = -I$(top_srcdir)/
+
diff --git a/recipes/clutter/clutter-gst/autofoo.patch b/recipes/clutter/clutter-gst/autofoo.patch
new file mode 100644
index 0000000000..569b0d8be9
--- /dev/null
+++ b/recipes/clutter/clutter-gst/autofoo.patch
@@ -0,0 +1,25 @@
+---
+ doc/reference/Makefile.am | 2 +-
+ examples/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: clutter-gst/examples/Makefile.am
+===================================================================
+--- clutter-gst.orig/examples/Makefile.am 2007-11-06 12:31:36.000000000 +0000
++++ clutter-gst/examples/Makefile.am 2007-11-06 18:53:59.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = video-player video-sink audio
++bin_PROGRAMS = video-player video-sink audio
+
+ INCLUDES = -I$(top_srcdir)/
+
+Index: clutter-gst/doc/reference/Makefile.am
+===================================================================
+--- clutter-gst.orig/doc/reference/Makefile.am 2007-11-06 19:36:56.000000000 +0000
++++ clutter-gst/doc/reference/Makefile.am 2007-11-06 19:37:02.000000000 +0000
+@@ -77,4 +77,4 @@ include $(top_srcdir)/gtk-doc.make
+
+ # Other files to distribute
+ # e.g. EXTRA_DIST += version.xml.in
+-EXTRA_DIST += version.xml.in
++EXTRA_DIST = version.xml.in
diff --git a/recipes/clutter/clutter-gst_0.4svn.bb b/recipes/clutter/clutter-gst_0.4svn.bb
new file mode 100644
index 0000000000..1af797888c
--- /dev/null
+++ b/recipes/clutter/clutter-gst_0.4svn.bb
@@ -0,0 +1,9 @@
+require clutter-gst.inc
+
+PV = "0.4.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/branches;module=clutter-gst-0-4;proto=http \
+ file://autofoo-0.4.patch;patch=1"
+
+
+S = "${WORKDIR}/clutter-gst-0-4"
diff --git a/recipes/clutter/clutter-gst_svn.bb b/recipes/clutter/clutter-gst_svn.bb
new file mode 100644
index 0000000000..8ef87236f7
--- /dev/null
+++ b/recipes/clutter/clutter-gst_svn.bb
@@ -0,0 +1,8 @@
+require clutter-gst.inc
+
+PV = "0.8.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=${PN};proto=http \
+ file://autofoo.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
diff --git a/recipes/clutter/clutter-gtk-0.6_git.bb b/recipes/clutter/clutter-gtk-0.6_git.bb
new file mode 100644
index 0000000000..89f2592bfc
--- /dev/null
+++ b/recipes/clutter/clutter-gtk-0.6_git.bb
@@ -0,0 +1,9 @@
+require clutter-gtk.inc
+
+PV = "0.6.0+git${SRCREV}"
+
+DEPENDS += "clutter-0.6"
+
+SRC_URI = "git://git.clutter-project.org/clutter-gtk.git;protocol=git;branch=clutter-gtk-0-6"
+
+S = "${WORKDIR}/git"
diff --git a/recipes/clutter/clutter-gtk-0.8_git.bb b/recipes/clutter/clutter-gtk-0.8_git.bb
new file mode 100644
index 0000000000..3fb0cff8aa
--- /dev/null
+++ b/recipes/clutter/clutter-gtk-0.8_git.bb
@@ -0,0 +1,9 @@
+require clutter-gtk.inc
+
+PV = "0.8.0+git${SRCREV}"
+
+DEPENDS += "clutter"
+
+SRC_URI = "git://git.clutter-project.org/clutter-gtk.git;protocol=git;branch=clutter-gtk-0-8"
+
+S = "${WORKDIR}/git"
diff --git a/recipes/clutter/clutter-gtk.inc b/recipes/clutter/clutter-gtk.inc
new file mode 100644
index 0000000000..bbecee548c
--- /dev/null
+++ b/recipes/clutter/clutter-gtk.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Clutter GTK+"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+DEPENDS = "gtk+"
+
+FILESPATH = "${FILE_DIRNAME}/clutter-gtk"
+
+PACKAGES =+ "${PN}-examples"
+FILES_${PN}-examples = "${bindir}/gtk-clutter-test ${bindir}/gtk-clutter-events ${bindir}/gtk-clutter-multistage"
+
+inherit autotools_stage pkgconfig gtk-doc
+
diff --git a/recipes/clutter/clutter-gtk_git.bb b/recipes/clutter/clutter-gtk_git.bb
new file mode 100644
index 0000000000..a3e3767f90
--- /dev/null
+++ b/recipes/clutter/clutter-gtk_git.bb
@@ -0,0 +1,10 @@
+require clutter-gst.inc
+
+PV = "0.9.0+git${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.clutter-project.org/clutter-gtk.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "clutter"
diff --git a/recipes/clutter/clutter.inc b/recipes/clutter/clutter.inc
new file mode 100644
index 0000000000..e900c43209
--- /dev/null
+++ b/recipes/clutter/clutter.inc
@@ -0,0 +1,64 @@
+DESCRIPTION = "Clutter graphics library"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+COMPATIBLE_MACHINE = "(zylonite|mx31litekit|omap-3430ldp|omap-3430sdp|mx31ads|qemuarm|qemux86|ipodtouch|beagleboard|overo|omap3evm)"
+
+STDDEPENDS = "virtual/libx11 gtk-doc-native pango glib-2.0 libxfixes gtk+"
+BASE_CONF = "--disable-gtk-doc ${@get_clutter_fpu_setting(bb, d)}"
+
+DEPENDS = "${STDDEPENDS} mesa"
+EXTRA_OECONF = "${BASE_CONF} --with-flavour=glx"
+
+DEPENDS_zylonite = "${STDDEPENDS} libgles-zylonite tslib"
+EXTRA_OECONF_zylonite = "${BASE_CONF} --with-flavour=eglnative"
+PACKAGE_ARCH_zylonite = "${MACHINE_ARCH}"
+LDFLAGS_append_zylonite = " -lnws -lstdc++ "
+
+DEPENDS_mx31litekit = "${STDDEPENDS} libgles-mx31 tslib"
+EXTRA_OECONF_mx31litekit = "${BASE_CONF} --with-flavour=eglnative"
+PACKAGE_ARCH_mx31litekit = "${MACHINE_ARCH}"
+LDFLAGS_append_mx31litekit = " -lpvrNULLWSEGL -lstdc++ "
+
+DEPENDS_omap-3430ldp = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_omap-3430ldp = "${BASE_CONF} --with-flavour=eglx"
+PACKAGE_ARCH_omap-3430ldp = "${MACHINE_ARCH}"
+
+DEPENDS_omap-3430sdp = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_omap-3430sdp = "${BASE_CONF} --with-flavour=eglx"
+PACKAGE_ARCH_omap-3430sdp = "${MACHINE_ARCH}"
+
+DEPENDS_beagleboard = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_beagleboard = "${BASE_CONF} --with-flavour=eglx --with-gles=2.0"
+PACKAGE_ARCH_beagleboard = "${MACHINE_ARCH}"
+
+DEPENDS_omap3evm = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_omap3evm = "${BASE_CONF} --with-flavour=eglx --with-gles=2.0"
+PACKAGE_ARCH_omap3evm = "${MACHINE_ARCH}"
+
+DEPENDS_overo = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_overo = "${BASE_CONF} --with-flavour=eglx --with-gles=2.0"
+PACKAGE_ARCH_overo = "${MACHINE_ARCH}"
+
+DEPENDS_mx31ads = "${STDDEPENDS} libgles-mx31 tslib"
+EXTRA_OECONF_mx31ads = "${BASE_CONF} --with-flavour=eglnative"
+PACKAGE_ARCH_mx31ads = "${MACHINE_ARCH}"
+LDFLAGS_append_mx31ads = " -lpvrNULLWSEGL -lstdc++ "
+
+inherit autotools pkgconfig gtk-doc
+
+PACKAGES =+ "clutter-examples"
+FILES_clutter-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
+
+#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require clutter-fpu.inc
+
+#Fix up some weirdness in the docs
+do_configure_prepend() {
+ sed -i s:doc/reference/Makefile::g ${S}/configure.ac
+ sed -i s:doc::g ${S}/Makefile.am
+}
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/clutter/clutter/enable-tests-r2990.patch b/recipes/clutter/clutter/enable-tests-r2990.patch
new file mode 100644
index 0000000000..4f449b1177
--- /dev/null
+++ b/recipes/clutter/clutter/enable-tests-r2990.patch
@@ -0,0 +1,50 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2008-06-26 16:46:26.000000000 +0100
++++ clutter/tests/Makefile.am 2008-06-26 16:46:50.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-perspective test-rotate test-depth \
+ test-threads test-timeline test-timeline-dup-frames \
+@@ -17,8 +17,8 @@
+ test-invariants
+
+ if X11_TESTS
+-noinst_PROGRAMS += test-pixmap
+-noinst_PROGRAMS += test-devices
++bin_PROGRAMS += test-pixmap
++bin_PROGRAMS += test-devices
+ endif
+
+ INCLUDES = -I$(top_srcdir)/ -I$(top_srcdir)/clutter -I$(top_builddir)/clutter
+@@ -73,4 +73,9 @@
+ test_invariants_SOURCES = test-invariants.c
+ test_devices_SOURCES = test-devices.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2008-06-26 16:46:26.000000000 +0100
++++ clutter/tests/test-actors.c 2008-06-26 16:46:31.000000000 +0100
+@@ -195,7 +195,7 @@
+ /* Create a texture from file, then clone in to same resources */
+ if (i == 0)
+ {
+- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
++ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
+ &error)) == NULL)
+ {
+ g_error ("image load failed: %s", error->message);
diff --git a/recipes/clutter/clutter/enable_tests-0.4.patch b/recipes/clutter/clutter/enable_tests-0.4.patch
new file mode 100644
index 0000000000..3178a2cd6c
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests-0.4.patch
@@ -0,0 +1,52 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter-0-4/tests/Makefile.am
+===================================================================
+--- clutter-0-4.orig/tests/Makefile.am 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/Makefile.am 2007-11-06 21:49:48.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-boxes test-perspective test-rotate test-depth \
+ test-threads test-timeline
+@@ -24,4 +24,9 @@ test_depth_SOURCES = test-depth.c
+ test_threads_SOURCES = test-threads.c
+ test_timeline_SOURCES = test-timeline.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png
+Index: clutter-0-4/tests/test-actors.c
+===================================================================
+--- clutter-0-4.orig/tests/test-actors.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-actors.c 2007-11-06 21:49:28.000000000 +0000
+@@ -143,7 +143,7 @@ main (int argc, char *argv[])
+ stage = clutter_stage_get_default ();
+ clutter_actor_set_size (stage, 800, 600);
+
+- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+
+ if (!pixbuf)
+ g_error("pixbuf load failed");
+Index: clutter-0-4/tests/test-text.c
+===================================================================
+--- clutter-0-4.orig/tests/test-text.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-text.c 2007-11-06 21:49:28.000000000 +0000
+@@ -27,7 +27,7 @@ main (int argc, char *argv[])
+
+ stage = clutter_stage_get_default ();
+
+- if (!g_file_get_contents ("test-text.c", &text, &size, NULL))
++ if (!g_file_get_contents ("/usr/share/clutter/test-text.c", &text, &size, NULL))
+ g_error("g_file_get_contents() of test-text.c failed");
+
+ clutter_actor_set_size (stage, 800, 600);
diff --git a/recipes/clutter/clutter/enable_tests-0.6.patch b/recipes/clutter/clutter/enable_tests-0.6.patch
new file mode 100644
index 0000000000..544a7e588c
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests-0.6.patch
@@ -0,0 +1,40 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter-0-6/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2007-11-06 12:29:17.000000000 +0000
++++ clutter-0-6/tests/Makefile.am 2007-11-06 12:30:11.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-boxes test-perspective test-rotate test-depth \
+ test-threads test-timeline test-score test-script
+@@ -26,4 +26,9 @@ test_timeline_SOURCES = test-timeline.c
+ test_score_SOURCES = test-score.c
+ test_script_SOURCES = test-script.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter-0-6/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2007-11-06 12:29:17.000000000 +0000
++++ clutter-0-6/tests/test-actors.c 2007-11-06 12:29:21.000000000 +0000
+@@ -143,7 +143,7 @@ main (int argc, char *argv[])
+ stage = clutter_stage_get_default ();
+ clutter_actor_set_size (stage, 800, 600);
+
+- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+
+ if (!pixbuf)
+ g_error("pixbuf load failed");
+
diff --git a/recipes/clutter/clutter/enable_tests.patch b/recipes/clutter/clutter/enable_tests.patch
new file mode 100644
index 0000000000..4a99968fa3
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests.patch
@@ -0,0 +1,48 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2008-04-25 16:45:17.000000000 +0100
++++ clutter/tests/Makefile.am 2008-04-25 16:47:12.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-perspective test-rotate test-depth \
+ test-threads test-timeline test-timeline-dup-frames \
+@@ -14,7 +14,7 @@
+ test-cogl-tex-polygon test-stage-read-pixels
+
+ if X11_TESTS
+-noinst_PROGRAMS += test-pixmap
++bin_PROGRAMS += test-pixmap
+ endif
+
+ INCLUDES = -I$(top_srcdir)/ -I$(top_builddir)/clutter
+@@ -61,4 +61,9 @@
+ test_cogl_offscreen_SOURCES = test-cogl-offscreen.c
+ test_stage_read_pixels_SOURCES = test-stage-read-pixels.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
++++ clutter/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
+@@ -184,7 +184,7 @@
+ /* Create a texture from file, then clone in to same resources */
+ if (i == 0)
+ {
+- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
++ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
+ &error)) == NULL)
+ {
+ g_error ("image load failed: %s", error->message);
diff --git a/recipes/clutter/clutter_0.4svn.bb b/recipes/clutter/clutter_0.4svn.bb
new file mode 100644
index 0000000000..fe1fbc29d3
--- /dev/null
+++ b/recipes/clutter/clutter_0.4svn.bb
@@ -0,0 +1,13 @@
+require clutter.inc
+
+PV = "0.4.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/branches;module=clutter-0-4;proto=http \
+ file://enable_tests-0.4.patch;patch=1 "
+
+S = "${WORKDIR}/clutter-0-4"
+
+do_stage () {
+ cp ${S}/clutter.pc ${S}/clutter-0.4.pc
+ autotools_stage_all
+}
diff --git a/recipes/clutter/clutter_0.6svn.bb b/recipes/clutter/clutter_0.6svn.bb
new file mode 100644
index 0000000000..79882d6ddf
--- /dev/null
+++ b/recipes/clutter/clutter_0.6svn.bb
@@ -0,0 +1,8 @@
+require clutter.inc
+
+PV = "0.6.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/branches;module=clutter-0-6;proto=http \
+ file://enable_tests-0.6.patch;patch=1 "
+
+S = "${WORKDIR}/clutter-0-6"
diff --git a/recipes/clutter/clutter_0.8+git.bb b/recipes/clutter/clutter_0.8+git.bb
new file mode 100644
index 0000000000..b578cbe43d
--- /dev/null
+++ b/recipes/clutter/clutter_0.8+git.bb
@@ -0,0 +1,13 @@
+require clutter.inc
+
+CLUTTER_REV = "7129ee4f1b86bfcb65b5fc39021b05b74168785d"
+
+PV = "0.8.7+gitr${CLUTTER_REV}"
+PR = "r0"
+SRC_URI = "git://git.clutter-project.org/clutter.git;protocol=git;branch=clutter-0-8;rev=${CLUTTER_REV} \
+ file://enable-tests-r2990.patch;patch=1"
+
+S = "${WORKDIR}/git"
+
+
+
diff --git a/recipes/clutter/clutter_svn.bb b/recipes/clutter/clutter_svn.bb
new file mode 100644
index 0000000000..cdcb2109e0
--- /dev/null
+++ b/recipes/clutter/clutter_svn.bb
@@ -0,0 +1,14 @@
+require clutter.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.8.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=clutter;proto=http \
+ file://enable_tests.patch;patch=1;maxrev=2989 \
+ file://enable-tests-r2990.patch;patch=1;minrev=2990"
+
+S = "${WORKDIR}/clutter"
+
+
diff --git a/recipes/clutter/moblin-proto/fix.patch b/recipes/clutter/moblin-proto/fix.patch
new file mode 100644
index 0000000000..8bde67762c
--- /dev/null
+++ b/recipes/clutter/moblin-proto/fix.patch
@@ -0,0 +1,22 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile 2008-08-11 22:49:48.000000000 +0100
++++ git/Makefile 2008-08-12 12:16:52.000000000 +0100
+@@ -15,7 +15,7 @@
+
+ SCP_DESTINATION=pug.vpn:tmp
+
+-BINARY=$(shell basename `pwd`)#
++BINARY=moblin-proto
+ PACKAGE=../$(BINARY).tar.bz2 # you can use both .gz and .bz2 as extension here
+
+ #CFLAGS= -Wall -I /home/pippin/src/clutter-box2d/clutter-box2d
+@@ -61,7 +61,7 @@
+ %.o: %.c $(HFILES)
+ $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@
+ $(BINARY): $(OBJECTS)
+- $(CC) -o $@ $(OBJECTS) $(LIBS)
++ $(CXX) -o $@ $(OBJECTS) $(LIBS)
+
+ #$(BINARY): $(CFILES)
+ # $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
diff --git a/recipes/clutter/moblin-proto/paths.patch b/recipes/clutter/moblin-proto/paths.patch
new file mode 100644
index 0000000000..d241c8ff71
--- /dev/null
+++ b/recipes/clutter/moblin-proto/paths.patch
@@ -0,0 +1,15 @@
+diff --git a/moblin-desktop.h b/moblin-desktop.h
+index 880a9ad..3d51a14 100644
+--- a/moblin-desktop.h
++++ b/moblin-desktop.h
+@@ -29,8 +29,8 @@
+ #define __MAIN_H__
+
+
+-#define ASSET_ROOT "./assets/"
+-#define JSON_ROOT "./layouts/"
++#define ASSET_ROOT "/usr/share/moblin-proto/assets/"
++#define JSON_ROOT "/usr/share/moblin-proto/layouts/"
+
+ typedef struct
+ {
diff --git a/recipes/clutter/moblin-proto_git.bb b/recipes/clutter/moblin-proto_git.bb
new file mode 100644
index 0000000000..3f61f496c5
--- /dev/null
+++ b/recipes/clutter/moblin-proto_git.bb
@@ -0,0 +1,19 @@
+DEPENDS = "clutter-box2d"
+
+PV = "0.0+gitr${SRCREV}"
+PR = "r1"
+PE = "1"
+
+SRC_URI = "git://git.moblin.org/repos/users/pippin/prototype.git/;protocol=http \
+ file://paths.patch;patch=1"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ install -d ${D}${bindir}
+ install ${S}/moblin-proto ${D}${bindir}
+
+ install -d ${D}${datadir}/moblin-proto/
+ cp -a ${S}/assets ${D}${datadir}/moblin-proto/
+ cp -a ${S}/layouts ${D}${datadir}/moblin-proto/
+}
diff --git a/recipes/clutter/table.inc b/recipes/clutter/table.inc
new file mode 100644
index 0000000000..6ee1672197
--- /dev/null
+++ b/recipes/clutter/table.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Table Clutter Demo"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+DEPENDS = "clutter-gst gnome-vfs"
+
+inherit autotools pkgconfig
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/table ${D}${bindir}/table
+}
+
+#do_stage () {
+# autotools_stage_all
+#}
+
diff --git a/recipes/clutter/table/fixes.patch b/recipes/clutter/table/fixes.patch
new file mode 100644
index 0000000000..a7cdc43713
--- /dev/null
+++ b/recipes/clutter/table/fixes.patch
@@ -0,0 +1,14 @@
+Index: table/Makefile
+===================================================================
+--- table.orig/Makefile 2007-07-10 13:24:18.000000000 +0100
++++ table/Makefile 2007-07-10 13:28:10.000000000 +0100
+@@ -8,7 +8,7 @@ all: table
+
+
+ table: table.o clutter-dominatrix.o clutter-video-player.o
+- $(CC) -g -Wall $(CFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS)
++ $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS)
+
+ clean:
+ rm -fr *.o table
+\ No newline at end of file
diff --git a/recipes/clutter/table_svn.bb b/recipes/clutter/table_svn.bb
new file mode 100644
index 0000000000..168ea4dfba
--- /dev/null
+++ b/recipes/clutter/table_svn.bb
@@ -0,0 +1,10 @@
+require table.inc
+
+PV = "0.3.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk/toys;module=table;proto=http \
+ file://fixes.patch;patch=1"
+
+S = "${WORKDIR}/table"
+
+
diff --git a/recipes/clutter/tidy.inc b/recipes/clutter/tidy.inc
new file mode 100644
index 0000000000..bac910a4f4
--- /dev/null
+++ b/recipes/clutter/tidy.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "Tidy library"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+STDDEPENDS = "clutter"
+BASE_CONF = "--disable-gtk-doc"
+
+DEPENDS = "${STDDEPENDS}"
+EXTRA_OECONF = "${BASE_CONF}"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ "tidy-examples"
+FILES_tidy-examples = "${bindir}/test-*"
+
+do_configure_prepend() {
+ touch ${S}/gtk-doc.make
+ sed -i s:docs/reference/Makefile::g ${S}/configure.ac
+ sed -i s:docs::g ${S}/Makefile.am
+}
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/clutter/tidy/autofoo.patch b/recipes/clutter/tidy/autofoo.patch
new file mode 100644
index 0000000000..7f54a3372a
--- /dev/null
+++ b/recipes/clutter/tidy/autofoo.patch
@@ -0,0 +1,11 @@
+Index: tidy/doc/reference/Makefile.am
+===================================================================
+--- tidy.orig/doc/reference/Makefile.am 2007-11-06 19:36:56.000000000 +0000
++++ tidy/doc/reference/Makefile.am 2007-11-06 19:37:02.000000000 +0000
+@@ -77,4 +77,4 @@ include $(top_srcdir)/gtk-doc.make
+
+ # Other files to distribute
+ # e.g. EXTRA_DIST += version.xml.in
+-EXTRA_DIST += version.xml.in
++EXTRA_DIST = version.xml.in
+
diff --git a/recipes/clutter/tidy/tidy-enable-tests.patch b/recipes/clutter/tidy/tidy-enable-tests.patch
new file mode 100644
index 0000000000..c5e1660c54
--- /dev/null
+++ b/recipes/clutter/tidy/tidy-enable-tests.patch
@@ -0,0 +1,20 @@
+Index: trunk/tests/Makefile.am
+===================================================================
+--- trunk.orig/tests/Makefile.am 2008-03-04 12:22:10.000000000 +0000
++++ trunk/tests/Makefile.am 2008-03-04 12:23:46.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = \
++bin_PROGRAMS = \
+ test-button \
+ test-finger-scroll \
+ test-list-view \
+@@ -14,6 +14,9 @@
+ test-grow \
+ test-viewport
+
++test_texture_framedir = $(pkgdatadir)
++test_texture_frame_DATA = frame.png
++
+ INCLUDES = -I$(top_srcdir)
+ LDADD = $(top_builddir)/tidy/libtidy-1.0.la
+
diff --git a/recipes/clutter/tidy_svn.bb b/recipes/clutter/tidy_svn.bb
new file mode 100644
index 0000000000..348bba0a8e
--- /dev/null
+++ b/recipes/clutter/tidy_svn.bb
@@ -0,0 +1,10 @@
+require tidy.inc
+
+PV = "0.1.0+svnr${SRCREV}"
+PR = "6"
+
+SRC_URI = "svn://svn.o-hand.com/repos/tidy;module=trunk;proto=http \
+ file://tidy-enable-tests.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+