aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cmake
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cmake')
-rw-r--r--recipes/cmake/cmake-native_2.4.8.bb12
-rw-r--r--recipes/cmake/cmake-native_2.6.0.bb11
-rw-r--r--recipes/cmake/cmake-native_2.6.3.bb11
-rw-r--r--recipes/cmake/cmake.inc19
-rw-r--r--recipes/cmake/cmake_2.4.8.bb1
5 files changed, 54 insertions, 0 deletions
diff --git a/recipes/cmake/cmake-native_2.4.8.bb b/recipes/cmake/cmake-native_2.4.8.bb
new file mode 100644
index 0000000000..02bc3aed48
--- /dev/null
+++ b/recipes/cmake/cmake-native_2.4.8.bb
@@ -0,0 +1,12 @@
+require cmake.inc
+inherit native
+
+do_stage() {
+ for i in cpack ctest ccmake cmake; do
+ install -m 0755 bin/$i ${STAGING_BINDIR_NATIVE}
+ done
+}
+
+do_install() {
+ :
+}
diff --git a/recipes/cmake/cmake-native_2.6.0.bb b/recipes/cmake/cmake-native_2.6.0.bb
new file mode 100644
index 0000000000..faf397614b
--- /dev/null
+++ b/recipes/cmake/cmake-native_2.6.0.bb
@@ -0,0 +1,11 @@
+inherit native
+require cmake.inc
+
+do_stage() {
+ oe_runmake install
+ autotools_stage_all
+}
+
+do_install() {
+ :
+}
diff --git a/recipes/cmake/cmake-native_2.6.3.bb b/recipes/cmake/cmake-native_2.6.3.bb
new file mode 100644
index 0000000000..faf397614b
--- /dev/null
+++ b/recipes/cmake/cmake-native_2.6.3.bb
@@ -0,0 +1,11 @@
+inherit native
+require cmake.inc
+
+do_stage() {
+ oe_runmake install
+ autotools_stage_all
+}
+
+do_install() {
+ :
+}
diff --git a/recipes/cmake/cmake.inc b/recipes/cmake/cmake.inc
new file mode 100644
index 0000000000..eb816680cd
--- /dev/null
+++ b/recipes/cmake/cmake.inc
@@ -0,0 +1,19 @@
+# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A cross-platform, open-source make system"
+HOMEPAGE = "http://www.cmake.org/"
+LICENSE = "Berkeley-style license"
+SECTION = "console/utils"
+PR = "r1"
+
+CMAKE_MAJOR_VERSION = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "http://www.cmake.org/files/v${CMAKE_MAJOR_VERSION}/cmake-${PV}.tar.gz"
+
+inherit autotools
+
+S = "${WORKDIR}/cmake-${PV}"
+
+do_configure () {
+ ./configure --prefix=${prefix} || die "./bootstrap failed"
+}
diff --git a/recipes/cmake/cmake_2.4.8.bb b/recipes/cmake/cmake_2.4.8.bb
new file mode 100644
index 0000000000..68f03c17a9
--- /dev/null
+++ b/recipes/cmake/cmake_2.4.8.bb
@@ -0,0 +1 @@
+require cmake.inc