aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cpio/files/install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cpio/files/install.patch')
-rw-r--r--recipes/cpio/files/install.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes/cpio/files/install.patch b/recipes/cpio/files/install.patch
new file mode 100644
index 0000000000..3554156ffc
--- /dev/null
+++ b/recipes/cpio/files/install.patch
@@ -0,0 +1,61 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- cpio-2.5/Makefile.in~install.patch
++++ cpio-2.5/Makefile.in
+@@ -70,6 +70,7 @@
+ # Prefix for each installed man page, normally empty or `g'.
+ manprefix =
+
++DESTDIR =
+
+ # Where to install the cpio and mt executables.
+ bindir = @bindir@
+@@ -123,19 +124,19 @@
+ $(CC) -c $(CPPFLAGS) $(DEFS) -I$(srcdir) $(CFLAGS) $<
+
+ install:: installdirs all $(srcdir)/cpio.1 $(srcdir)/mt.1
+- $(INSTALL_PROGRAM) cpio $(bindir)/$(binprefix)cpio
+- test ! -f mt || $(INSTALL_PROGRAM) mt $(bindir)/$(binprefix)mt
+- -test ! -f rmt || $(INSTALL_PROGRAM) rmt $(libexecdir)/rmt
+- -$(INSTALL_DATA) $(srcdir)/cpio.1 $(mandir)/$(manprefix)cpio.$(manext)
+- -test ! -f mt || $(INSTALL_DATA) $(srcdir)/mt.1 $(mandir)/$(manprefix)mt.$(manext)
++ $(INSTALL_PROGRAM) -D cpio $(DESTDIR)$(bindir)/$(binprefix)cpio
++ test ! -f mt || $(INSTALL_PROGRAM) -D mt $(DESTDIR)$(bindir)/$(binprefix)mt
++ -test ! -f rmt || $(INSTALL_PROGRAM) -D rmt $(DESTDIR)$(libexecdir)/rmt
++ -$(INSTALL_DATA) -D $(srcdir)/cpio.1 $(DESTDIR)$(mandir)/$(manprefix)cpio.$(manext)
++ -test ! -f mt || $(INSTALL_DATA) -D $(srcdir)/mt.1 $(DESTDIR)$(mandir)/$(manprefix)mt.$(manext)
+
+ installdirs:
+- $(srcdir)/mkinstalldirs $(bindir) $(libexecdir) $(mandir) $(infodir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)/$(bindir) $(DESTDIR)/$(libexecdir) $(DESTDIR)/$(mandir) $(DESTDIR)/$(infodir)
+
+ uninstall::
+- cd $(bindir); rm -f $(binprefix)cpio $(binprefix)mt
+- -rm -f $(libexecdir)/rmt
+- cd $(mandir); rm -f $(manprefix)cpio.$(manext) $(manprefix)mt.$(manext)
++ cd $(DESTDIR)$(bindir); rm -f $(binprefix)cpio $(binprefix)mt
++ -rm -f $(DESTDIR)$(libexecdir)/rmt
++ cd $(DESTDIR)$(mandir); rm -f $(manprefix)cpio.$(manext) $(manprefix)mt.$(manext)
+
+ check:
+ @echo No tests are supplied.
+@@ -186,14 +187,14 @@
+
+ install-info: $(INFO_DEPS)
+ for file in *.info*; do \
+- $(INSTALL_DATA) $$file $(infodir)/$$file; \
++ $(INSTALL_DATA) -D $$file $(DESTDIR)$(infodir)/$$file; \
+ done
+
+ uninstall:: uninstall-info
+
+ uninstall-info:
+ for file in *.info*; do \
+- rm -f $(infodir)/$$file; \
++ rm -f $(DESTDIR)$(infodir)/$$file; \
+ done
+
+ clean: