aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cpubench/cpubench_06.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cpubench/cpubench_06.bb')
-rw-r--r--recipes/cpubench/cpubench_06.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/cpubench/cpubench_06.bb b/recipes/cpubench/cpubench_06.bb
new file mode 100644
index 0000000000..82735310b6
--- /dev/null
+++ b/recipes/cpubench/cpubench_06.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "OpenWRT's CPU Benchmark"
+HOMEPAGE = "http://wiki.openwrt.org/HardwarePerformance"
+LICENSE = "GPL"
+SECTION = "devel"
+
+SRC_URI = "file://openwrt_cpu_bench_v06.c"
+
+do_compile() {
+ ${CC} -O0 ${LDFLAGS} ${WORKDIR}/openwrt_cpu_bench_v06.c -o cpubench
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 cpubench ${D}${bindir}
+}