aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cpuburn
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cpuburn')
-rw-r--r--recipes/cpuburn/cpuburn/gcc_CC.patch19
-rw-r--r--recipes/cpuburn/cpuburn_1.4.bb25
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes/cpuburn/cpuburn/gcc_CC.patch b/recipes/cpuburn/cpuburn/gcc_CC.patch
new file mode 100644
index 0000000000..a572754eb0
--- /dev/null
+++ b/recipes/cpuburn/cpuburn/gcc_CC.patch
@@ -0,0 +1,19 @@
+--- cpuburn-1.4/Makefile.orig 2006-03-09 16:11:53.368477664 -0700
++++ cpuburn-1.4/Makefile 2006-03-09 16:13:27.053235416 -0700
+@@ -1,3 +1,15 @@
++prefix=/usr/local
++
+ all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
+ .S:
+- gcc -s -nostdlib -o $@ $<
++ ${CC} ${CFLAGS} -s -nostdlib -o $@ $<
++
++install:
++ install -d ${DESTDIR}${prefix}/bin
++ install -m 0755 burnP5 ${DESTDIR}${prefix}/bin
++ install -m 0755 burnP6 ${DESTDIR}${prefix}/bin
++ install -m 0755 burnK6 ${DESTDIR}${prefix}/bin
++ install -m 0755 burnK7 ${DESTDIR}${prefix}/bin
++ install -m 0755 burnBX ${DESTDIR}${prefix}/bin
++ install -m 0755 burnMMX ${DESTDIR}${prefix}/bin
++
diff --git a/recipes/cpuburn/cpuburn_1.4.bb b/recipes/cpuburn/cpuburn_1.4.bb
new file mode 100644
index 0000000000..a3d1264212
--- /dev/null
+++ b/recipes/cpuburn/cpuburn_1.4.bb
@@ -0,0 +1,25 @@
+# cpuburn OE build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="CPU testing utilities in optimized assembler for maximum loading P6, K7, K6, P5 chips"
+HOMEPAGE="http://pages.sbcglobal.net/redelm/"
+LICENSE="GPL"
+
+SRC_URI="http://pages.sbcglobal.net/redelm/${PN}_1_4_tar.gz \
+ file://gcc_CC.patch;patch=1"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ bb.build.exec_func('cpuburn_do_unpack', d)
+}
+
+cpuburn_do_unpack () {
+ tar xvf ${PN}_1_4_tar
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+