aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cpusage/cpusage_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cpusage/cpusage_0.1.bb')
-rw-r--r--recipes/cpusage/cpusage_0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/cpusage/cpusage_0.1.bb b/recipes/cpusage/cpusage_0.1.bb
new file mode 100644
index 0000000000..d90c630ceb
--- /dev/null
+++ b/recipes/cpusage/cpusage_0.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "This tool read out the tics counter of the operating system and \
+calculates the Percentages spend in each CPU_STATE."
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www8.in.tum.de/~schneifa/group/sources/cpusage-${PV}.tar.gz \
+ file://cpusage.patch;patch=1"
+
+S = "${WORKDIR}/cpusage-${PV}"
+
+FILES_${PN} = "/sbin/cpusage"
+
+CFLAGS_append =" -D_BSD_SOURCE=1"
+CFLAGS_append = '${@base_conditional("KERNEL_MAJOR_VERSION", "2.6", " -D__Linux26__ ", " -D__Linux24__ ",d)}'
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o cpusage cpusage.c
+}
+
+do_install() {
+ install -d ${D}${base_sbindir}
+ install -m 0755 cpusage ${D}${base_sbindir}/cpusage
+}