aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cramfs/cramfs-native_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cramfs/cramfs-native_1.1.bb')
-rw-r--r--recipes/cramfs/cramfs-native_1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/cramfs/cramfs-native_1.1.bb b/recipes/cramfs/cramfs-native_1.1.bb
new file mode 100644
index 0000000000..062a704ea5
--- /dev/null
+++ b/recipes/cramfs/cramfs-native_1.1.bb
@@ -0,0 +1,27 @@
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/cramfs"
+
+DESCRIPTION="Builds cramfs filesystems for embedded systems"
+SECTION = "base"
+LICENSE="GPL"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cramfs/cramfs-1.1.tar.gz \
+ file://makefile.patch;patch=1 \
+ file://cramfs-andersee.patch;patch=1"
+
+DEPENDS = "zlib-native"
+
+S = "${WORKDIR}/cramfs-${PV}"
+
+inherit native
+
+do_compile() {
+ oe_runmake all
+}
+
+do_stage() {
+ install -m 755 mkcramfs ${STAGING_BINDIR}
+ install -m 755 cramfsck ${STAGING_BINDIR}
+}
+