aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cramfs/cramfs_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cramfs/cramfs_cvs.bb')
-rw-r--r--recipes/cramfs/cramfs_cvs.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/cramfs/cramfs_cvs.bb b/recipes/cramfs/cramfs_cvs.bb
new file mode 100644
index 0000000000..812f3f113f
--- /dev/null
+++ b/recipes/cramfs/cramfs_cvs.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Builds cramfs filesystems for embedded systems"
+LICENSE = "GPLv2"
+DEPENDS = "zlib"
+SRCDATE = "20110110"
+PV = "1.1+cvs${SRCDATE}"
+
+SRC_URI = "cvs://anonymous@cramfs.cvs.sourceforge.net/cvsroot/cramfs;module=linux"
+S = "${WORKDIR}/linux/scripts/cramfs"
+
+EXTRA_OEMAKE = "\
+ 'CC=${CC}' \
+ 'CFLAGS=${CFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+"
+
+BBCLASSEXTEND = "native"
+
+do_install() {
+ install -d ${D}${bindir}
+ install mkcramfs ${D}${bindir}
+ install cramfsck ${D}${bindir}
+}
+
+NATIVE_INSTALL_WORKS = "1"