aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cumulus
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cumulus')
-rw-r--r--recipes/cumulus/cumulus/open_max.patch11
-rw-r--r--recipes/cumulus/cumulus/qtooltip.patch27
-rw-r--r--recipes/cumulus/cumulus_1.2.1.bb43
-rw-r--r--recipes/cumulus/cumulus_cvs.bb44
4 files changed, 125 insertions, 0 deletions
diff --git a/recipes/cumulus/cumulus/open_max.patch b/recipes/cumulus/cumulus/open_max.patch
new file mode 100644
index 0000000000..0a7cfccdbf
--- /dev/null
+++ b/recipes/cumulus/cumulus/open_max.patch
@@ -0,0 +1,11 @@
+--- cumulus/gpscon.cpp.old 2008-11-18 23:39:12.000000000 +0000
++++ cumulus/gpscon.cpp 2008-11-18 23:43:32.000000000 +0000
+@@ -416,7 +416,7 @@
+
+ if( maxOpenFds == -1 ) // call failed
+ {
+- maxOpenFds = OPEN_MAX; // normal default from limits.h
++ maxOpenFds = sysconf(_SC_OPEN_MAX);
+ }
+ else
+ {
diff --git a/recipes/cumulus/cumulus/qtooltip.patch b/recipes/cumulus/cumulus/qtooltip.patch
new file mode 100644
index 0000000000..b36b9676a7
--- /dev/null
+++ b/recipes/cumulus/cumulus/qtooltip.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- cumulus/whatsthat.cpp~qtooltip 2004-01-24 12:00:59.000000000 +0100
++++ cumulus/whatsthat.cpp 2004-01-29 19:30:04.000000000 +0100
+@@ -16,7 +16,7 @@
+ ***********************************************************************/
+
+ #include "whatsthat.h"
+-#include <qtooltip.h>
++#include "./qtooltip.h"
+ #include <qstylesheet.h>
+ #include <qapplication.h>
+ #include <qpainter.h>
+--- cumulus/qtooltip.h~qtooltip 2004-01-24 12:01:00.000000000 +0100
++++ cumulus/qtooltip.h 2004-01-29 19:31:16.000000000 +0100
+@@ -43,7 +43,7 @@
+ public:
+ QToolTip(){};
+ ~QToolTip(){};
+- QPalette palette();
++ static QPalette palette();
+ };
+
+ #endif
diff --git a/recipes/cumulus/cumulus_1.2.1.bb b/recipes/cumulus/cumulus_1.2.1.bb
new file mode 100644
index 0000000000..dec0b51e9e
--- /dev/null
+++ b/recipes/cumulus/cumulus_1.2.1.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "A flightcomputer application for Qt/E based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPNAME = "cumulus"
+APPDESKTOP = "${S}"
+PR = "r1"
+
+SRC_URI = "http://www.kflog.org/fileadmin/user_upload/cumulus_downloads/${PV}/cumulus-${PV}.src.tar.bz2 \
+ file://open_max.patch;patch=1"
+S = "${WORKDIR}/cumulus_${PV}/cumulus"
+
+inherit opie
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=-I."
+
+#
+# nasty hack since cumulus doesn't obey the qmake standard which requires just one .pro file per directory
+#
+do_compile() {
+ echo "#define SHARP_PDA_WARNSOUND 4" >sharp_char.h
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} cumulus.pro
+ oe_runmake
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} gpsClient.pro
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/mapicons \
+ ${D}${palmtopdir}/pics/mapicons/small \
+ ${D}${palmtopdir}/pics/mapicons/windarrows \
+ ${D}${palmtopdir}/bin
+ install -m 0644 ../cumulus.png ${D}${palmtopdir}/pics/cumulus.png
+ install -m 0644 map-icons/*.png ${D}${palmtopdir}/pics/mapicons
+ install -m 0644 map-icons/*.xpm ${D}${palmtopdir}/pics/mapicons
+ install -m 0644 map-icons/small/*.png ${D}${palmtopdir}/pics/mapicons/small
+ install -m 0644 map-icons/small/*.xpm ${D}${palmtopdir}/pics/mapicons/small
+ install -m 0644 map-icons/windarrows/*.png ${D}${palmtopdir}/pics/mapicons/windarrows
+
+ install -m 0755 gpsClient ${D}${palmtopdir}/bin/
+}
diff --git a/recipes/cumulus/cumulus_cvs.bb b/recipes/cumulus/cumulus_cvs.bb
new file mode 100644
index 0000000000..133e0e704f
--- /dev/null
+++ b/recipes/cumulus/cumulus_cvs.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "A flightcomputer application for Qt/E based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPNAME = "cumulus"
+APPDESKTOP = "${S}"
+PV = "${OPIE_CVS_PV}"
+PR = "r0"
+
+SRC_URI = "http://www.kflog.org/fileadmin/user_upload/cumulus_snapshots/cumulus-snapshot.tbz"
+S = "${WORKDIR}/cumulus/cumulus"
+
+inherit opie
+
+DEFAULT_PREFERENCE = "-1"
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=-I."
+
+#
+# nasty hack since cumulus doesn't obey the qmake standard which requires just one .pro file per directory
+#
+do_compile() {
+ echo "#define SHARP_PDA_WARNSOUND 4" >sharp_char.h
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} cumulus.pro
+ oe_runmake
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} gpsClient.pro
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/cumulus \
+ ${D}${palmtopdir}/pics/cumulus/small \
+ ${D}${palmtopdir}/pics/cumulus/windarrows
+ install -m 0644 ../cumulus.png ${D}${palmtopdir}/pics/cumulus/cumulus.png
+ install -m 0644 map-icons/*.png ${D}${palmtopdir}/pics/cumulus
+ install -m 0644 map-icons/*.xpm ${D}${palmtopdir}/pics/cumulus
+ install -m 0644 map-icons/small/*.png ${D}${palmtopdir}/pics/cumulus/small
+ install -m 0644 map-icons/small/*.xpm ${D}${palmtopdir}/pics/cumulus/small
+ install -m 0644 map-icons/windarrows/*.png ${D}${palmtopdir}/pics/cumulus/windarrows
+
+ install -m 0755 gpsClient ${D}${palmtopdir}/bin/
+}