aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/curl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/curl')
-rw-r--r--recipes/curl/curl-native_7.18.2.bb12
-rw-r--r--recipes/curl/curl-sdk_7.18.2.bb14
-rw-r--r--recipes/curl/curl.inc80
-rw-r--r--recipes/curl/curl_7.18.2.bb2
-rw-r--r--recipes/curl/curl_7.19.0.bb5
-rw-r--r--recipes/curl/files/pkgconfig_fix.patch35
-rw-r--r--recipes/curl/off_t_abi_fix.patch17
7 files changed, 165 insertions, 0 deletions
diff --git a/recipes/curl/curl-native_7.18.2.bb b/recipes/curl/curl-native_7.18.2.bb
new file mode 100644
index 0000000000..f0e2b8940e
--- /dev/null
+++ b/recipes/curl/curl-native_7.18.2.bb
@@ -0,0 +1,12 @@
+require curl_${PV}.bb
+inherit native
+DEPENDS = "zlib-native"
+
+do_stage () {
+ autotools_stage_all
+}
+
+do_install() {
+ :
+}
+
diff --git a/recipes/curl/curl-sdk_7.18.2.bb b/recipes/curl/curl-sdk_7.18.2.bb
new file mode 100644
index 0000000000..816fe645bc
--- /dev/null
+++ b/recipes/curl/curl-sdk_7.18.2.bb
@@ -0,0 +1,14 @@
+require curl_${PV}.bb
+inherit sdk
+DEPENDS = "zlib-sdk"
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/curl
+ install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
+ oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
+}
+
+do_install() {
+ :
+}
+
diff --git a/recipes/curl/curl.inc b/recipes/curl/curl.inc
new file mode 100644
index 0000000000..d3edaef20a
--- /dev/null
+++ b/recipes/curl/curl.inc
@@ -0,0 +1,80 @@
+DESCRIPTION = "Command line tool and library for client-side URL transfers."
+LICENSE = "MIT"
+SECTION = "console/network"
+
+SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
+ file://pkgconfig_fix.patch;patch=1"
+S = "${WORKDIR}/curl-${PV}"
+
+CURL_FEATURES ?= "zlib,gnutls,cookies,crypto-auth,dict,file,ftp,http,telnet,tftp"
+# other allowed features: ipv6, ares
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = " \
+ --without-libssh2 \
+ --with-random=/dev/urandom \
+ --without-libidn \
+ --without-ssl \
+ "
+
+python __anonymous() {
+ f = bb.data.getVar("CURL_FEATURES", d, True).split(",")
+ oeconf = bb.data.getVar("EXTRA_OECONF", d, False)
+ deps = bb.data.getVar("DEPENDS", d, False).split()
+ for x in [ 'cookies', 'crypto-auth', 'dict', 'file', 'ftp', 'http', 'telnet', 'tftp', 'ipv6' ]:
+ if x in f:
+ oeconf += " --enable-%s" % x
+ else:
+ oeconf += " --disable-%s" % x
+ if 'zlib' in f:
+ oeconf += " --with-zlib=${STAGING_LIBDIR}/../"
+ deps.append("zlib")
+ else:
+ oeconf += " --without-zlib"
+ if 'gnutls' in f:
+ oeconf += " --with-gnutls=${STAGING_BINDIR_CROSS}"
+ deps.append("gnutls")
+ else:
+ oeconf += " --without-gnutls"
+ if 'ares' in f:
+ oeconf += " --enable-ares"
+ deps.append("c-ares")
+ else:
+ oeconf += " --disable-ares"
+ bb.data.setVar('EXTRA_OECONF', oeconf, d)
+ bb.data.setVar('DEPENDS', " ".join(deps), d)
+}
+
+do_configure_prepend() {
+ sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/curl
+ install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
+ oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
+}
+
+PACKAGES += "${PN}-certs libcurl libcurl-dev libcurl-doc"
+
+FILES_${PN} = "${bindir}/curl"
+
+FILES_${PN}-certs = "${datadir}/curl/curl-*"
+PACKAGE_ARCH_${PN}-certs = "all"
+
+FILES_${PN}-doc = "${mandir}/man1/curl.1"
+
+FILES_lib${PN} = "${libdir}/lib*.so.*"
+RRECOMMENDS_lib${PN} += "${PN}-certs"
+FILES_lib${PN}-dev = "${includedir} \
+ ${libdir}/lib*.so \
+ ${libdir}/lib*.a \
+ ${libdir}/lib*.la \
+ ${libdir}/pkgconfig \
+ ${datadir}/aclocal \
+ ${bindir}/*-config"
+
+FILES_lib${PN}-doc = "${mandir}/man3 \
+ ${mandir}/man1/curl-config.1"
+
diff --git a/recipes/curl/curl_7.18.2.bb b/recipes/curl/curl_7.18.2.bb
new file mode 100644
index 0000000000..2c3ec415f5
--- /dev/null
+++ b/recipes/curl/curl_7.18.2.bb
@@ -0,0 +1,2 @@
+require curl.inc
+
diff --git a/recipes/curl/curl_7.19.0.bb b/recipes/curl/curl_7.19.0.bb
new file mode 100644
index 0000000000..a99a68bcb1
--- /dev/null
+++ b/recipes/curl/curl_7.19.0.bb
@@ -0,0 +1,5 @@
+require curl.inc
+
+SRC_URI += "file://off_t_abi_fix.patch;patch=1;pnum=0"
+PR = "r1"
+
diff --git a/recipes/curl/files/pkgconfig_fix.patch b/recipes/curl/files/pkgconfig_fix.patch
new file mode 100644
index 0000000000..e02316a73a
--- /dev/null
+++ b/recipes/curl/files/pkgconfig_fix.patch
@@ -0,0 +1,35 @@
+Index: curl-7.16.4/libcurl.pc.in
+===================================================================
+--- curl-7.16.4.orig/libcurl.pc.in 2007-02-18 09:41:27.000000000 +0000
++++ curl-7.16.4/libcurl.pc.in 2008-03-18 11:42:43.000000000 +0000
+@@ -33,6 +33,7 @@
+ URL: http://curl.haxx.se/
+ Description: Library to transfer files with ftp, http, etc.
+ Version: @VERSION@
+-Libs: -L${libdir} -lcurl @LDFLAGS@ @LIBS@
+-Libs.private: @LIBCURL_LIBS@ @LIBS@
++Requires.private: @GNUTLS_REQUIRED@
++Libs: -L${libdir} -lcurl
++Libs.private: -ldl -lz
+ Cflags: -I${includedir}
+Index: curl-7.16.4/configure.ac
+===================================================================
+--- curl-7.16.4.orig/configure.ac 2008-03-18 11:40:30.000000000 +0000
++++ curl-7.16.4/configure.ac 2008-03-18 11:42:06.000000000 +0000
+@@ -1361,6 +1361,7 @@
+ AC_SUBST(USE_GNUTLS, [1])
+ GNUTLS_ENABLED=1
+ USE_GNUTLS="yes"
++ GNUTLS_REQUIRED="gnutls"
+ curl_ssl_msg="enabled (GnuTLS)"
+ ],
+ [
+@@ -1387,6 +1388,8 @@
+
+ fi dnl OPENSSL != 1
+
++AC_SUBST(GNUTLS_REQUIRED)
++
+ dnl ----------------------------------------------------
+ dnl NSS. Only check if GnuTLS and OpenSSL are not enabled
+ dnl ----------------------------------------------------
diff --git a/recipes/curl/off_t_abi_fix.patch b/recipes/curl/off_t_abi_fix.patch
new file mode 100644
index 0000000000..007f0404ff
--- /dev/null
+++ b/recipes/curl/off_t_abi_fix.patch
@@ -0,0 +1,17 @@
+--- configure.ac~ 2008-09-07 16:53:11.000000000 +0100
++++ configure.ac 2008-09-09 08:49:29.000000000 +0100
+@@ -1998,6 +1998,14 @@
+ CURL_CHECK_STRUCT_TIMEVAL
+ CURL_VERIFY_RUNTIMELIBS
+
++if test x"$ac_cv_sys_file_offset_bits" == "x64"; then
++ if test "${ac_cv_sizeof_large_off_t+set}" = set; then
++ ac_cv_sizeof_off_t=$ac_cv_sizeof_large_off_t
++ else
++ unset ac_cv_sizeof_off_t
++ fi
++fi
++
+ AC_CHECK_SIZEOF(size_t)
+ AC_CHECK_SIZEOF(int)
+ AC_CHECK_SIZEOF(long)