aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cxcrypt/cxcrypt_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cxcrypt/cxcrypt_1.0.bb')
-rw-r--r--recipes/cxcrypt/cxcrypt_1.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/cxcrypt/cxcrypt_1.0.bb b/recipes/cxcrypt/cxcrypt_1.0.bb
new file mode 100644
index 0000000000..705859319b
--- /dev/null
+++ b/recipes/cxcrypt/cxcrypt_1.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "A simple, xor-based encryption tool"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.fh-wedel.de/pub/fh-wedel/staff/herbert/misc/${PN}-${PV}.tar.gz"
+S = "${WORKDIR}/cxcrypt"
+
+CFLAGS_prepend = "-g -Wall -ansi -pedantic "
+LDFLAGS_prepend = "-L. -lcxio "
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d -m 755 ${D}/usr/bin
+ install -d -m 755 ${D}/usr/lib
+ install -d -m 755 ${D}/usr/include
+ install -m 755 cxcrypt ${D}/usr/bin
+ install -m 755 libcxio.a ${D}/usr/lib
+ install -m 755 cxio.h ${D}/usr/include
+}
+
+do_stage() {
+ install -d -m 755 ${STAGING_INCDIR}
+ install -d -m 755 ${STAGING_LIBDIR}
+ install -m 644 cxio.h ${STAGING_INCDIR}
+ install -m 644 libcxio.a ${STAGING_LIBDIR}
+}
+
+FILES_${PN} = "/usr/bin/${PN}"
+FILES_${PN}-dev = "/usr/lib/libcxio.a /usr/include"
+