aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cyrus-imapd/cyrus-imapd-2.2.12
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cyrus-imapd/cyrus-imapd-2.2.12')
-rw-r--r--recipes/cyrus-imapd/cyrus-imapd-2.2.12/autotools.patch69
-rw-r--r--recipes/cyrus-imapd/cyrus-imapd-2.2.12/imapopts.c.gcc4.patch11
-rw-r--r--recipes/cyrus-imapd/cyrus-imapd-2.2.12/imapopts.h.gcc4.patch11
-rw-r--r--recipes/cyrus-imapd/cyrus-imapd-2.2.12/remove-install-strip.patch45
-rw-r--r--recipes/cyrus-imapd/cyrus-imapd-2.2.12/tail.patch8
5 files changed, 144 insertions, 0 deletions
diff --git a/recipes/cyrus-imapd/cyrus-imapd-2.2.12/autotools.patch b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/autotools.patch
new file mode 100644
index 0000000000..a7f5e64396
--- /dev/null
+++ b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/autotools.patch
@@ -0,0 +1,69 @@
+--- tmp/base/cyrus-imapd-2.2.5-r0/cyrus-imapd-2.2.5/configure.in 2004-05-28 14:03:00.000000000 -0400
++++ cyrus-imapd-2.2.5/configure.in 2004-06-04 21:42:20.745944000 -0400
+@@ -997,6 +997,16 @@
+ IMAP_COM_ERR_LIBS="${COM_ERR_LIBS}"
+ IMAP_LIBS="${LIB_SASL} ${LIBS}"
+
++if test "x$BUILD_CC" = "x"; then
++ BUILD_CC="$(CC)"
++fi
++if test "x$BUILD_CFLAGS" = "x"; then
++ BUILD_CFLAGS="$(CFLAGS)"
++fi
++if test "x$BUILD_LDFLAGS" = "x"; then
++ BUILD_LDFLAGS="$(LDFLAGS)"
++fi
++
+ AC_SUBST(LIB_RT)
+ AC_SUBST(IMAP_COM_ERR_LIBS)
+ AC_SUBST(IMAP_LIBS)
+@@ -1010,6 +1020,9 @@
+ AC_SUBST(PERL_SUBDIRS)
+ AC_SUBST(PERL_DEPSUBDIRS)
+ AC_SUBST(PERL)
++AC_SUBST(BUILD_CC)
++AC_SUBST(BUILD_LDFLAGS)
++AC_SUBST(BUILD_CFLAGS)
+
+ AH_TOP([
+ /* $Id: configure.in,v 1.286 2004/05/28 18:03:00 rjs3 Exp $ */
+--- tmp/base/cyrus-imapd-2.2.5-r0/cyrus-imapd-2.2.5/lib/Makefile.in 2004-05-28 14:03:04.000000000 -0400
++++ cyrus-imapd-2.2.5/lib/Makefile.in 2004-06-04 21:40:57.325068000 -0400
+@@ -53,6 +53,7 @@
+ VPATH = @srcdir@
+
+ CC = @CC@
++BUILD_CC = @BUILD_CC@
+
+ INSTALL = @INSTALL@
+ RANLIB = @RANLIB@
+@@ -63,7 +64,9 @@
+
+ MAKEDEPEND_CFLAGS = @CFLAGS@
+ CFLAGS = @CFLAGS@ @PERL_CCCDLFLAGS@
++BUILD_CFLAGS = @BUILD_CFLAGS@
+ LDFLAGS = @LDFLAGS@
++BUILD_LDFLAGS = @BUILD_LDFLAGS@
+
+ SHELL = /bin/sh
+ MAKEDEPEND = @MAKEDEPEND@
+@@ -149,8 +152,17 @@
+ # ./mkchartable -m $(srcdir)/charset/unicode.map $(srcdir)/charset/*.t >x-chartables.h
+ # mv x-chartables.h chartables.h
+
+-mkchartable: mkchartable.o xmalloc.o assert.o
+- $(CC) $(LDFLAGS) -o mkchartable mkchartable.o xmalloc.o assert.o
++mkchartable: mkchartable.native.o xmalloc.native.o assert.native.o
++ $(BUILD_CC) $(BUILD_LDFLAGS) -o mkchartable mkchartable.native.o xmalloc.native.o assert.native.o
++
++xmalloc.native.o: xmalloc.c
++ $(BUILD_CC) $(BUILD_CFLAGS) -c -o xmalloc.native.o xmalloc.c
++
++assert.native.o: assert.c
++ $(BUILD_CC) $(BUILD_CFLAGS) -c -o assert.native.o assert.c
++
++mkchartable.native.o: mkchartable.c
++ $(BUILD_CC) $(BUILD_CFLAGS) -c -o mkchartable.native.o mkchartable.c
+
+ clean:
+ rm -f *.o *.a chartable.c Makefile.bak mkchartable makedepend.log \
diff --git a/recipes/cyrus-imapd/cyrus-imapd-2.2.12/imapopts.c.gcc4.patch b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/imapopts.c.gcc4.patch
new file mode 100644
index 0000000000..821fc9ad7f
--- /dev/null
+++ b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/imapopts.c.gcc4.patch
@@ -0,0 +1,11 @@
+--- cyrus-imapd-2.2.12/lib/imapopts.c.orig 2006-08-10 14:43:19.000000000 +0200
++++ cyrus-imapd-2.2.12/lib/imapopts.c 2006-08-10 14:43:48.000000000 +0200
+@@ -24,7 +24,7 @@
+
+
+
+-struct imapopt_s imapopts[] =
++struct imapopt_s * imapopts =
+
+ {
+
diff --git a/recipes/cyrus-imapd/cyrus-imapd-2.2.12/imapopts.h.gcc4.patch b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/imapopts.h.gcc4.patch
new file mode 100644
index 0000000000..d1ab605801
--- /dev/null
+++ b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/imapopts.h.gcc4.patch
@@ -0,0 +1,11 @@
+--- cyrus-imapd-2.2.12/lib/imapopts.h.orig 2006-08-10 14:43:26.000000000 +0200
++++ cyrus-imapd-2.2.12/lib/imapopts.h 2006-08-10 14:44:58.000000000 +0200
+@@ -178,7 +178,7 @@
+
+ };
+
+-extern struct imapopt_s imapopts[];
++extern struct imapopt_s * imapopts;
+
+
+
diff --git a/recipes/cyrus-imapd/cyrus-imapd-2.2.12/remove-install-strip.patch b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/remove-install-strip.patch
new file mode 100644
index 0000000000..bb43d16516
--- /dev/null
+++ b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/remove-install-strip.patch
@@ -0,0 +1,45 @@
+---
+ cyrus-imapd-2.2.12/imtest/Makefile.in | 2 +-
+ cyrus-imapd-2.2.12/installsieve/Makefile.in | 2 +-
+ cyrus-imapd-2.2.12/netnews/Makefile.in | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+Index: cyrus-imapd-2.2.12/imtest/Makefile.in
+===================================================================
+--- cyrus-imapd-2.2.12.orig/imtest/Makefile.in
++++ cyrus-imapd-2.2.12/imtest/Makefile.in
+@@ -72,7 +72,7 @@
+ all: imtest
+
+ install:
+- $(INSTALL) -s -m 755 imtest $(DESTDIR)$(exec_prefix)/bin
++ $(INSTALL) -m 755 imtest $(DESTDIR)$(exec_prefix)/bin
+ ln -f $(DESTDIR)$(exec_prefix)/bin/imtest $(DESTDIR)$(exec_prefix)/bin/pop3test
+ ln -f $(DESTDIR)$(exec_prefix)/bin/imtest $(DESTDIR)$(exec_prefix)/bin/nntptest
+ ln -f $(DESTDIR)$(exec_prefix)/bin/imtest $(DESTDIR)$(exec_prefix)/bin/lmtptest
+Index: cyrus-imapd-2.2.12/installsieve/Makefile.in
+===================================================================
+--- cyrus-imapd-2.2.12.orig/installsieve/Makefile.in
++++ cyrus-imapd-2.2.12/installsieve/Makefile.in
+@@ -66,7 +66,7 @@
+ all: installsieve
+
+ install:
+- $(INSTALL) -s -m 755 installsieve $(DESTDIR)$(exec_prefix)/bin
++ $(INSTALL) -m 755 installsieve $(DESTDIR)$(exec_prefix)/bin
+
+ OBJS=lex.o mystring.o request.o isieve.o
+
+Index: cyrus-imapd-2.2.12/netnews/Makefile.in
+===================================================================
+--- cyrus-imapd-2.2.12.orig/netnews/Makefile.in
++++ cyrus-imapd-2.2.12/netnews/Makefile.in
+@@ -69,7 +69,7 @@
+ all: remotepurge
+
+ install:
+- $(INSTALL) -s -m 755 remotepurge $(DESTDIR)$(service_path)
++ $(INSTALL) -m 755 remotepurge $(DESTDIR)$(service_path)
+
+ .c.o:
+ $(CC) -c $(CPPFLAGS) $(DEFS) $(CFLAGS) $<
diff --git a/recipes/cyrus-imapd/cyrus-imapd-2.2.12/tail.patch b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/tail.patch
new file mode 100644
index 0000000000..38a3ecbac6
--- /dev/null
+++ b/recipes/cyrus-imapd/cyrus-imapd-2.2.12/tail.patch
@@ -0,0 +1,8 @@
+--- cyrus-imapd-2.2.5/imap/xversion.sh.orig 2003-10-22 20:03:00 +0200
++++ cyrus-imapd-2.2.5/imap/xversion.sh 2004-08-26 16:57:29 +0200
+@@ -22,4 +22,4 @@
+ match ($0, pattern) {
+ printf "\"%s\"\n", substr($0, RSTART, RLENGTH)
+ }' pattern="$DATEPAT $TIMEPAT" | \
+- sort | tail -1 >> xversion.h
++ sort | tail -n 1 >> xversion.h