aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cyrus-sasl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cyrus-sasl')
-rw-r--r--recipes/cyrus-sasl/cyrus-sasl-2.1.17/configure.patch193
-rw-r--r--recipes/cyrus-sasl/cyrus-sasl-2.1.19/berkdb.m4.patch13
-rw-r--r--recipes/cyrus-sasl/cyrus-sasl-2.1.19/client.c.patch11
-rw-r--r--recipes/cyrus-sasl/cyrus-sasl_2.1.17.bb42
-rw-r--r--recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb41
-rw-r--r--recipes/cyrus-sasl/cyrus-sasl_2.1.19.bb53
6 files changed, 353 insertions, 0 deletions
diff --git a/recipes/cyrus-sasl/cyrus-sasl-2.1.17/configure.patch b/recipes/cyrus-sasl/cyrus-sasl-2.1.17/configure.patch
new file mode 100644
index 0000000000..e1780b77e4
--- /dev/null
+++ b/recipes/cyrus-sasl/cyrus-sasl-2.1.17/configure.patch
@@ -0,0 +1,193 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- cyrus-sasl-2.1.17/configure.in~configure
++++ cyrus-sasl-2.1.17/configure.in
+@@ -123,7 +123,7 @@
+ AC_DEFINE(TRY_DLOPEN_WHEN_STATIC,[],[Should we try to dlopen() plugins while staticly compiled?])
+ fi
+
+-if test "$ac_cv_prog_gcc" = yes; then
++if test "$ac_cv_c_compiler_gnu" = yes; then
+ CFLAGS="-Wall -W ${CFLAGS}"
+ fi
+
+@@ -143,7 +143,7 @@
+ AC_PATH_PROGS(JAVAH, javah kaffeh, no)
+ AC_CHECK_PROGS(JAVADOC, javadoc, :)
+ if test "$JAVAC" = "no" -o "$JAVAH" = "no"; then
+- AC_WARN([Disabling Java support])
++ AC_MSG_WARN([Disabling Java support])
+ enable_java=no
+ fi
+ else
+@@ -363,7 +363,7 @@
+ LDFLAGS="$LDFLAGS -L$digest/lib"
+ fi
+ if test "$with_des" = no; then
+- AC_WARN(No DES support for DIGEST-MD5)
++ AC_MSG_WARN([No DES support for DIGEST-MD5])
+ fi
+ fi
+
+@@ -385,7 +385,7 @@
+ otp=yes)
+
+ if test "$with_openssl" = no; then
+- AC_WARN([OpenSSL not found -- OTP will be disabled])
++ AC_MSG_WARN([OpenSSL not found -- OTP will be disabled])
+ otp=no
+ fi
+
+@@ -441,7 +441,7 @@
+ srp=no)
+
+ if test "$with_openssl" = no; then
+- AC_WARN([OpenSSL not found -- SRP will be disabled])
++ AC_MSG_WARN([OpenSSL not found -- SRP will be disabled])
+ srp=no
+ fi
+
+@@ -522,7 +522,7 @@
+ ntlm=no)
+
+ if test "$with_openssl" = no; then
+- AC_WARN([OpenSSL not found -- NTLM will be disabled])
++ AC_MSG_WARN([OpenSSL not found -- NTLM will be disabled])
+ ntlm=no
+ fi
+
+@@ -839,7 +839,7 @@
+ AC_CHECK_FUNC(snprintf, [AC_DEFINE(HAVE_SNPRINTF,[],[Does the system have snprintf()?])], [sasl_cv_snprintf=yes])
+ AC_CHECK_FUNC(vsnprintf, [AC_DEFINE(HAVE_VSNPRINTF,[],[Does the system have vsnprintf()?])], [sasl_cv_snprintf=yes])
+ if test $sasl_cv_snprintf = yes; then
+- LIBOBJS="$LIBOBJS snprintf.o"
++ AC_LIBOBJ([snprintf])
+ SNPRINTFOBJS="snprintf.o"
+ LTSNPRINTFOBJS="snprintf.lo"
+ fi
+@@ -856,7 +856,7 @@
+ [AC_DEFINE(HAVE_GETADDRINFO,[],[Do we have a getaddrinfo() function?])
+ sasl_cv_getaddrinfo=no])])
+ if test $sasl_cv_getaddrinfo = yes; then
+- LIBOBJS="$LIBOBJS getaddrinfo.o"
++ AC_LIBOBJ([getaddrinfo])
+ GETADDRINFOOBJS="getaddrinfo.o"
+ LTGETADDRINFOOBJS="getaddrinfo.lo"
+ fi
+@@ -869,16 +869,16 @@
+ IPv6_CHECK_FUNC(getnameinfo,
+ [AC_DEFINE(HAVE_GETNAMEINFO,[],[Do we have a getnameinfo() function?])], [sasl_cv_getnameinfo=yes])
+ if test $sasl_cv_getnameinfo = yes; then
+- LIBOBJS="$LIBOBJS getnameinfo.o"
++ AC_LIBOBJ([getnameinfo])
+ GETNAMEINFOOBJS="getnameinfo.o"
+ LTGETNAMEINFOOBJS="getnameinfo.lo"
+ fi
+ AC_SUBST(GETNAMEINFOOBJS)
+ AC_SUBST(LTGETNAMEINFOOBJS)
+
+-LTLIBOBJS=`echo "$LIBOBJS" | sed 's/\.o/.lo/g'`
+-AC_SUBST(LIBOBJS)
+-AC_SUBST(LTLIBOBJS)
++#LTLIBOBJS=`echo "$LIBOBJS" | sed 's/\.o/.lo/g'`
++#AC_SUBST(LIBOBJS)
++#AC_SUBST(LTLIBOBJS)
+
+ AC_C_CONST
+ AC_C_INLINE
+@@ -1092,7 +1092,7 @@
+
+ AC_CONFIG_HEADERS(config.h)
+
+-AC_OUTPUT(Makefile
++AC_CONFIG_FILES([Makefile
+ include/Makefile
+ sasldb/Makefile
+ plugins/Makefile
+@@ -1108,6 +1108,7 @@
+ java/javax/security/auth/Makefile
+ java/javax/security/auth/callback/Makefile
+ pwcheck/Makefile
+-man/Makefile)
++man/Makefile])
++AC_OUTPUT
+
+ echo Configuration Complete. Type \'make\' to build.
+--- cyrus-sasl-2.1.17/saslauthd/auth_rimap.c~configure
++++ cyrus-sasl-2.1.17/saslauthd/auth_rimap.c
+@@ -59,6 +59,7 @@
+ /* PUBLIC DEPENDENCIES */
+ #include "mechanisms.h"
+
++#include <config.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <assert.h>
+--- cyrus-sasl-2.1.17/saslauthd/auth_sia.c~configure
++++ cyrus-sasl-2.1.17/saslauthd/auth_sia.c
+@@ -36,6 +36,7 @@
+
+ #ifdef AUTH_SIA
+
++#include <libio.h> /* NULL */
+ #include <string.h>
+ #include <sia.h>
+ #include <siad.h>
+--- cyrus-sasl-2.1.17/saslauthd/configure.in~configure
++++ cyrus-sasl-2.1.17/saslauthd/configure.in
+@@ -61,7 +61,7 @@
+ AC_DEFINE(HAVE_SIA,[],[Include SIA Support])
+ LIB_SIA="-lsecurity -ldb -lm -laud"
+ else
+- AC_ERROR([No support for SIA found])
++ AC_MSG_ERROR([No support for SIA found])
+ fi
+ fi
+ AC_SUBST(LIB_SIA)
+@@ -298,6 +298,42 @@
+ #endif
+ ])
+
++AH_TEMPLATE([AUTH_SASLDB], [])
++AH_TEMPLATE([HAVE_FUNC], [])
++AH_TEMPLATE([HAVE_FUNCTION], [])
++AH_TEMPLATE([HAVE_GSSAPI], [])
++AH_TEMPLATE([HAVE_LDAP], [])
++AH_TEMPLATE([HAVE_PAM], [])
++AH_TEMPLATE([HAVE_PRETTY_FUNCTION], [])
++AH_TEMPLATE([HAVE_SASLAUTHD], [])
++AH_TEMPLATE([HAVE_SIA], [])
++AH_TEMPLATE([HAVE_STRUCT_SOCKADDR_STORAGE], [])
++AH_TEMPLATE([KRB5_HEIMDAL], [])
++AH_TEMPLATE([PATH_SASLAUTHD_RUNDIR], [])
++AH_TEMPLATE([SASLAUTHD_THREADED], [])
++AH_TEMPLATE([USE_DOORS], [])
++AH_TEMPLATE([HAVE_GETADDRINFO], [])
++AH_TEMPLATE([HAVE_GETNAMEINFO], [])
++AH_TEMPLATE([HAVE_OPENSSL], [])
++AH_TEMPLATE([HAVE_SOCKADDR_SA_LEN], [])
++AH_TEMPLATE([HAVE_SOCKLEN_T], [])
++AH_TEMPLATE([HAVE_SS_FAMILY], [])
++AH_TEMPLATE([HAVE_GETADDRINFO], [])
++AH_TEMPLATE([HAVE_GETNAMEINFO], [])
++AH_TEMPLATE([HAVE_OPENSSL], [])
++AH_TEMPLATE([HAVE_SOCKADDR_SA_LEN], [])
++AH_TEMPLATE([HAVE_SOCKLEN_T], [])
++AH_TEMPLATE([HAVE_SS_FAMILY], [])
++AH_TEMPLATE([HAVE_KRB], [])
++AH_TEMPLATE([SASL_BERKELEYDB], [])
++AH_TEMPLATE([SASL_DB_PATH], [])
++AH_TEMPLATE([SASL_GDBM], [])
++AH_TEMPLATE([SASL_NDBM], [])
++AH_TEMPLATE([STATIC_KERBEROS4], [])
++AH_TEMPLATE([STATIC_SASLDB], [])
++AH_TEMPLATE([WITH_DES], [])
++AH_TEMPLATE([WITH_SSL_DES], [])
+ AC_CONFIG_HEADERS(saslauthd.h)
+
+-AC_OUTPUT(Makefile)
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
diff --git a/recipes/cyrus-sasl/cyrus-sasl-2.1.19/berkdb.m4.patch b/recipes/cyrus-sasl/cyrus-sasl-2.1.19/berkdb.m4.patch
new file mode 100644
index 0000000000..abfc3475c6
--- /dev/null
+++ b/recipes/cyrus-sasl/cyrus-sasl-2.1.19/berkdb.m4.patch
@@ -0,0 +1,13 @@
+# This patch adds config support for recognising (and therefore using)
+# version 4.3 of the BerkelyDB
+--- cyrus-sasl-2.1.19/cmulocal/berkdb.m4.orig 2005-07-10 23:09:33.323172813 -0700
++++ cyrus-sasl-2.1.19/cmulocal/berkdb.m4 2005-07-10 23:09:49.866665096 -0700
+@@ -211,7 +211,7 @@
+ BDB_LIBADD=""
+ fi
+
+- for dbname in db-4.2 db4.2 db42 db-4.1 db4.1 db41 db-4.0 db4.0 db-4 db40 db4 db-3.3 db3.3 db33 db-3.2 db3.2 db32 db-3.1 db3.1 db31 db-3 db30 db3 db
++ for dbname in db-4.3 db4.3 db-4.2 db4.2 db42 db-4.1 db4.1 db41 db-4.0 db4.0 db-4 db40 db4 db-3.3 db3.3 db33 db-3.2 db3.2 db32 db-3.1 db3.1 db31 db-3 db30 db3 db
+ do
+ AC_CHECK_LIB($dbname, db_create, BDB_LIBADD="$BDB_LIBADD -l$dbname";
+ dblib="berkeley"; break, dblib="no")
diff --git a/recipes/cyrus-sasl/cyrus-sasl-2.1.19/client.c.patch b/recipes/cyrus-sasl/cyrus-sasl-2.1.19/client.c.patch
new file mode 100644
index 0000000000..775bc54faa
--- /dev/null
+++ b/recipes/cyrus-sasl/cyrus-sasl-2.1.19/client.c.patch
@@ -0,0 +1,11 @@
+--- xx/lib/client.c.orig 2006-07-01 12:32:46.000000000 +0200
++++ xx/lib/client.c 2006-07-01 12:33:01.000000000 +0200
+@@ -61,7 +61,7 @@
+
+ static cmech_list_t *cmechlist; /* global var which holds the list */
+
+-static sasl_global_callbacks_t global_callbacks;
++sasl_global_callbacks_t global_callbacks;
+
+ static int _sasl_client_active = 0;
+
diff --git a/recipes/cyrus-sasl/cyrus-sasl_2.1.17.bb b/recipes/cyrus-sasl/cyrus-sasl_2.1.17.bb
new file mode 100644
index 0000000000..00cad2d6d6
--- /dev/null
+++ b/recipes/cyrus-sasl/cyrus-sasl_2.1.17.bb
@@ -0,0 +1,42 @@
+SECTION = "console/network"
+DEPENDS = "virtual/db"
+DESCRIPTION = "Generic client/server library for SASL authentication."
+LICENSE = "BSD"
+
+PR = "r1"
+
+SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/OLD-VERSIONS/sasl/cyrus-sasl-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+acpaths = "-I ${S}/cmulocal -I ${S}/config -I ."
+CFLAGS_append = " -I${S}/include -I${S}/saslauthd/include"
+EXTRA_OECONF = "--enable-shared --enable-static --with-dblib=berkeley \
+ --with-bdb-libdir=${STAGING_LIBDIR} \
+ --with-bdb-incdir=${STAGING_INCDIR} \
+ --without-opie --without-des"
+
+do_configure_prepend () {
+ rm -f acinclude.m4 config/libtool.m4
+}
+
+do_compile_prepend () {
+ cd include
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makemd5.c -o makemd5
+ touch makemd5.o makemd5.lo makemd5
+ cd ..
+}
+
+do_stage () {
+ oe_libinstall -so -a -C lib libsasl2 ${STAGING_LIBDIR}
+ install -d ${STAGING_LIBDIR}/sasl
+ install -d ${STAGING_INCDIR}/sasl
+ install -m 0644 ${S}/include/hmac-md5.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/md5.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/md5global.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/sasl.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/saslplug.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/saslutil.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/prop.h ${STAGING_INCDIR}/sasl/
+}
diff --git a/recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb b/recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb
new file mode 100644
index 0000000000..a863d3e5ad
--- /dev/null
+++ b/recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb
@@ -0,0 +1,41 @@
+SECTION = "console/network"
+DEPENDS = "virtual/db"
+DESCRIPTION = "Generic client/server library for SASL authentication."
+LICENSE = "BSD"
+
+PR = "r1"
+
+SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/OLD-VERSIONS/sasl/cyrus-sasl-${PV}.tar.gz"
+
+inherit autotools
+
+acpaths = "-I ${S}/cmulocal -I ${S}/config -I ."
+CFLAGS_append = " -I${S}/include -I${S}/saslauthd/include"
+EXTRA_OECONF = "--enable-shared --enable-static --with-dblib=berkeley \
+ --with-bdb-libdir=${STAGING_LIBDIR} \
+ --with-bdb-incdir=${STAGING_INCDIR} \
+ --without-opie --without-des"
+
+do_configure_prepend () {
+ rm -f acinclude.m4 config/libtool.m4
+}
+
+do_compile_prepend () {
+ cd include
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makemd5.c -o makemd5
+ touch makemd5.o makemd5.lo makemd5
+ cd ..
+}
+
+do_stage () {
+ oe_libinstall -so -a -C lib libsasl2 ${STAGING_LIBDIR}
+ install -d ${STAGING_LIBDIR}/sasl
+ install -d ${STAGING_INCDIR}/sasl
+ install -m 0644 ${S}/include/hmac-md5.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/md5.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/md5global.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/sasl.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/saslplug.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/saslutil.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/prop.h ${STAGING_INCDIR}/sasl/
+}
diff --git a/recipes/cyrus-sasl/cyrus-sasl_2.1.19.bb b/recipes/cyrus-sasl/cyrus-sasl_2.1.19.bb
new file mode 100644
index 0000000000..b179298355
--- /dev/null
+++ b/recipes/cyrus-sasl/cyrus-sasl_2.1.19.bb
@@ -0,0 +1,53 @@
+SECTION = "console/network"
+DEPENDS = "openssl virtual/db"
+DESCRIPTION = "Generic client/server library for SASL authentication."
+LICENSE = "BSD"
+PR = "r10"
+
+SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-${PV}.tar.gz \
+ file://berkdb.m4.patch;patch=1 \
+ file://client.c.patch;patch=1"
+
+inherit autotools
+
+acpaths = "-I ${S}/cmulocal -I ${S}/config -I ."
+CFLAGS_append = " -I${S}/include -I${S}/saslauthd/include"
+TARGET_LDFLAGS_append_thumb = " -lpthread"
+EXTRA_OECONF = "--enable-shared --enable-static --with-dblib=berkeley \
+ --with-bdb-libdir=${STAGING_LIBDIR} \
+ --with-bdb-incdir=${STAGING_INCDIR} \
+ --without-pam \
+ --without-opie --without-des"
+
+FILES_${PN} += "${prefix}/lib/sasl2/*.so*"
+FILES_${PN}-dev += "${libdir}/sasl2/*.la ${libdir}/sasl2/*.a"
+
+do_configure_prepend () {
+ rm -f acinclude.m4 config/libtool.m4
+}
+
+do_compile_prepend () {
+ cd include
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makemd5.c -o makemd5
+ touch makemd5.o makemd5.lo makemd5
+ cd ..
+}
+
+do_stage () {
+ oe_libinstall -so -a -C lib libsasl2 ${STAGING_LIBDIR}
+ install -d ${STAGING_LIBDIR}/sasl2
+ install -d ${STAGING_INCDIR}/sasl
+ install -m 0644 ${S}/include/hmac-md5.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/md5.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/md5global.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/sasl.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/saslplug.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/saslutil.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/prop.h ${STAGING_INCDIR}/sasl/
+}
+
+pkg_postinst () {
+ grep cyrus /etc/passwd || adduser --disabled-password --home=/var/spool/mail --ingroup mail -g "Cyrus sasl" cyrus
+ echo "cyrus" | saslpasswd2 -p -c cyrus
+ chgrp mail /etc/sasldb2
+}