aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dash/dash_0.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dash/dash_0.5.2.bb')
-rw-r--r--recipes/dash/dash_0.5.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/dash/dash_0.5.2.bb b/recipes/dash/dash_0.5.2.bb
new file mode 100644
index 0000000000..ee4e8c1bd6
--- /dev/null
+++ b/recipes/dash/dash_0.5.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The Debian Almquist Shell is a POSIX compliant shell that is much smaller than 'bash'."
+PROVIDES = "virtual/sh"
+LICENSE = "BSD GPL"
+PR = "r1"
+
+SRC_URI = "http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}.orig.tar.gz \
+ http://snapshot.debian.net/archive/2005/07/11/debian/pool/main/d/dash/dash_0.5.2-6.diff.gz;patch=1 \
+ file://makefile-build-cc.diff;patch=1"
+
+inherit autotools
+
+bindir = "/bin"
+PREFIX="${bindir}"
+
+# dont use update-alternatives class because since we are dealing with /bin/sh
+# we need to do the remove in pkg_prerm where the /bin/sh link still points
+# to something (postrm is a shell script)
+
+ALTERNATIVE_NAME = "sh"
+ALTERNATIVE_PATH = "${bindir}/dash"
+ALTERNATIVE_PRIORITY = "10"
+ALTERNATIVE_LINK = "${bindir}/${ALTERNATIVE_NAME}"
+
+pkg_postinst() {
+update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
+}
+
+pkg_prerm() {
+update-alternatives --remove ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH}
+}