aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbh
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dbh')
-rw-r--r--recipes/dbh/dbh-1.0-18/configure.patch42
-rw-r--r--recipes/dbh/dbh_1.0-18.bb18
2 files changed, 60 insertions, 0 deletions
diff --git a/recipes/dbh/dbh-1.0-18/configure.patch b/recipes/dbh/dbh-1.0-18/configure.patch
new file mode 100644
index 0000000000..50cc7403a5
--- /dev/null
+++ b/recipes/dbh/dbh-1.0-18/configure.patch
@@ -0,0 +1,42 @@
+Index: dbh_1.0-18/configure.ac
+===================================================================
+--- dbh_1.0-18.orig/configure.ac 2004-03-16 16:02:20.000000000 -0700
++++ dbh_1.0-18/configure.ac 2005-04-06 12:30:01.900159452 -0700
+@@ -34,6 +34,8 @@
+
+ dnl Initialize libtool
+ AC_CANONICAL_HOST
++AC_CANONICAL_TARGET
++
+ # libtool.m4 is a bit outof sync.
+ AC_PROG_LIBTOOL
+
+@@ -122,17 +124,17 @@
+
+
+ dnl echo "dbg:target $target"
+-case "$target" in
+-"")
+-;;
+-"no")
+-;;
+-"NONE")
+-;;
+-*)
+- CFLAGS="$CFLAGS -march=$target"
+- ;;
+-esac
++dnl case "$target" in
++dnl "")
++dnl ;;
++dnl "no")
++dnl ;;
++dnl "NONE")
++dnl ;;
++dnl *)
++dnl CFLAGS="$CFLAGS -march=$target_cpu"
++dnl ;;
++dnl esac
+
+ # At present, only 32 bit system.
+
diff --git a/recipes/dbh/dbh_1.0-18.bb b/recipes/dbh/dbh_1.0-18.bb
new file mode 100644
index 0000000000..c15349f6fd
--- /dev/null
+++ b/recipes/dbh/dbh_1.0-18.bb
@@ -0,0 +1,18 @@
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+DESCRIPTION ="Disk based hashes is a method to create multidimensional binary trees on disk."
+HOMEPAGE = "http://dbh.sourceforge.net"
+LICENSE = "GPL"
+SECTION = "libs"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/dbh/dbh_${PV}.tar.bz2 \
+ file://${FILESDIR}/configure.patch;patch=1"
+
+S="${WORKDIR}/dbh_${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+autotools_stage_all
+}