aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus/dbus-c++-native_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dbus/dbus-c++-native_svn.bb')
-rw-r--r--recipes/dbus/dbus-c++-native_svn.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/dbus/dbus-c++-native_svn.bb b/recipes/dbus/dbus-c++-native_svn.bb
new file mode 100644
index 0000000000..5599aeb1d2
--- /dev/null
+++ b/recipes/dbus/dbus-c++-native_svn.bb
@@ -0,0 +1,21 @@
+require dbus-c++_${PV}.bb
+inherit native
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-c++"
+# actually dbus-native and expat-native, but even the bearest build machine should have that nowadays...
+DEPENDS = ""
+
+do_compile() {
+ oe_runmake -C src libdbus-c++-1.la
+ oe_runmake -C tools dbusxx-xml2cpp
+ install -m 0755 tools/dbusxx-xml2cpp ${STAGING_BINDIR_NATIVE}
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ :
+}
+