summaryrefslogtreecommitdiffstats
path: root/recipes/dbus/dbus-glib-native_0.74.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dbus/dbus-glib-native_0.74.bb')
-rw-r--r--recipes/dbus/dbus-glib-native_0.74.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/dbus/dbus-glib-native_0.74.bb b/recipes/dbus/dbus-glib-native_0.74.bb
new file mode 100644
index 0000000000..e37a64cfea
--- /dev/null
+++ b/recipes/dbus/dbus-glib-native_0.74.bb
@@ -0,0 +1,21 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "Message bus system for applications to talk to one another"
+LICENSE = "GPL"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://run-with-tmp-session-bus.patch;patch=1"
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-glib-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-glib-${PV}"
+DEPENDS = "glib-2.0-native dbus-native"
+
+do_stage() {
+ oe_runmake install
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 tools/dbus-bus-introspect.xml ${STAGING_DATADIR}/dbus
+ install -m 0644 tools/dbus-glib-bindings.h ${STAGING_DATADIR}/dbus
+}