aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus/dbus.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dbus/dbus.inc')
-rw-r--r--recipes/dbus/dbus.inc19
1 files changed, 12 insertions, 7 deletions
diff --git a/recipes/dbus/dbus.inc b/recipes/dbus/dbus.inc
index 2c41eb12c9..55a156d8f5 100644
--- a/recipes/dbus/dbus.inc
+++ b/recipes/dbus/dbus.inc
@@ -4,14 +4,14 @@ SECTION = "base"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl libsm libice virtual/libx11"
-INC_PR = "r18"
+INC_PR = "r19"
SRC_URI = "\
http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz;name=dbus \
- file://cross.patch;patch=1 \
- file://tmpdir.patch;patch=1 \
- file://fix-install-daemon.patch;patch=1 \
- file://0001-Make-the-default-DBus-reply-timeout-configurable.patch;patch=1 \
+ file://cross.patch \
+ file://tmpdir.patch \
+ file://fix-install-daemon.patch \
+ file://0001-Make-the-default-DBus-reply-timeout-configurable.patch \
file://dbus-1.init \
"
@@ -35,8 +35,13 @@ EXTRA_OECONF = "\
${EXTRA_OECONF_X} \
"
-do_compile_prepend_mipsel() {
- sed -i -e 's/\-fPIE//' -e 's/\-pie\ \-Wl\,\-z\,relro//' bus/Makefile
+# On mipsel, D-Bus fails to link with --gc-sections and segfaults before main()
+# when built with -fPIE/-pie.
+do_configure_prepend_mipsel() {
+ sed -i -e 's/\-fPIE//' \
+ -e 's/\-pie\ \-Wl\,\-z\,relro//' \
+ -e 's/-Wl,--gc-sections//' \
+ ${S}/configure.in
}
do_install_append() {