aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dcron
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dcron')
-rw-r--r--recipes/dcron/dcron-2.3.3/compile.patch29
-rw-r--r--recipes/dcron/dcron-2.3.3/strip.patch16
-rw-r--r--recipes/dcron/dcron_2.3.3.bb18
3 files changed, 63 insertions, 0 deletions
diff --git a/recipes/dcron/dcron-2.3.3/compile.patch b/recipes/dcron/dcron-2.3.3/compile.patch
new file mode 100644
index 0000000000..2787facb22
--- /dev/null
+++ b/recipes/dcron/dcron-2.3.3/compile.patch
@@ -0,0 +1,29 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dcron-2.3.3/subs.c~compile
++++ dcron-2.3.3/subs.c
+@@ -15,7 +15,6 @@
+ Prototype int ChangeUser(const char *user, short dochdir);
+ Prototype void vlog(int level, int fd, const char *ctl, va_list va);
+ Prototype int slog(char *buf, size_t sz, const char *ctl, va_list va, short useDate);
+-Prototype char *strdup(const char *);
+
+ void
+ log9(const char *ctl, ...)
+@@ -131,6 +130,7 @@
+ return(pas->pw_uid);
+ }
+
++#if 0
+ char *
+ strdup(const char *str)
+ {
+@@ -140,4 +140,4 @@
+ strcpy(ptr, str);
+ return(ptr);
+ }
+-
++#endif
diff --git a/recipes/dcron/dcron-2.3.3/strip.patch b/recipes/dcron/dcron-2.3.3/strip.patch
new file mode 100644
index 0000000000..51aef07f2d
--- /dev/null
+++ b/recipes/dcron/dcron-2.3.3/strip.patch
@@ -0,0 +1,16 @@
+Index: dcron-2.3.3/Makefile
+===================================================================
+--- dcron-2.3.3.orig/Makefile 2006-06-19 15:47:35.774568368 +0200
++++ dcron-2.3.3/Makefile 2006-06-19 15:47:43.713361488 +0200
+@@ -14,11 +14,9 @@
+
+ crond: ${OBJS}
+ ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB}
+- strip crond
+
+ crontab: ${D_OBJS}
+ ${CC} ${CFLAGS} -o crontab ${D_OBJS}
+- strip crontab
+
+ protos.h: ${SRCS} ${D_SRCS}
+ fgrep -h Prototype ${SRCS} ${D_SRCS} >protos.h
diff --git a/recipes/dcron/dcron_2.3.3.bb b/recipes/dcron/dcron_2.3.3.bb
new file mode 100644
index 0000000000..d965bbecca
--- /dev/null
+++ b/recipes/dcron/dcron_2.3.3.bb
@@ -0,0 +1,18 @@
+SECTION = "base"
+DESCRIPTION = "Dillon's Cron is a multi-user cron written from scratch, \
+similar to vixie-cron but with major differences."
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/dcron-${PV}.tar.gz \
+ file://compile.patch;patch=1 \
+ file://strip.patch;patch=1"
+
+do_install () {
+ install -d ${D}${bindir} ${D}${sbindir} \
+ ${D}${mandir}/man1 ${D}${mandir}/man8
+ install -m 0755 crond ${D}${sbindir}/
+ install -m 4755 crontab ${D}${bindir}/
+ install crontab.1 ${D}${mandir}/man1
+ install crond.8 ${D}${mandir}/man8
+}